Page MenuHome

Materials turn black and are exported to FBX as halfway transparent (when imported into Unity)
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10 x64
Graphics card: Nvidia Quadro M2000 - 12248 MB of available graphics memory (4096 Dedicated Video Memory)

Blender Version
Broken: blender2.8, 2018-12-03

Short description of error
Materials turn black randomly and stay that way. Very difficult to get them back displaying properly again.
Also, exports transparent materials to FBX (rendered as transparent material when importing to Unity 2018.3...)

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  1. Delete the startup cube.
  2. Extract to desktop and Import this .dae file: https://www.models-resource.com/wii/bombermanblast/model/2349/
  3. Use scale tool and scale down to ~2m tall (using incremental scale)
  4. Click around, change selections, and zoom camera around model; Change between the various new shading modes and transparency in the Layout viewport.
  5. Hop to the UV Editor tab, then back to main Layout tab (back and forth), maybe click on the bones/armature in the outliner in the Layout and do various selections

Eventually the materials will turn black.
It will be very difficult to get them back to displaying correctly without reimporting the images -- and sometimes not even then.
It appears to be at random, and only sometimes can you get the materials back before they disappear again after switching tabs to the UV Editor.

Tweaking the Principled BDSF "Base Color" property of the second material to "Image Texture" and swapping between linked materials/textures eventually causes a crash.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce here.

Also please do not report multiple issues in a single report.
Also please be more specific what you mean by:

  • "second material" [which is the 'second']?
  • "swapping between linked materials/textures"

To sum it up: we need a reproducable case (with exact steps to achieve this) to be able to investigate this.
Marking as incomplete until required information is given...

Zachary (AFWS) added a subscriber: Zachary (AFWS).EditedJan 4 2019, 2:17 PM

@Philipp Oeser (lichtwerk)

I’ve experienced materials going black ,but it happened once or twice and I can't reproduce it. I was working on some double sided cards and 1/4 of them turned black, started to show the color on the back, and then blender crashed. It's almost as if you did the following.

Card has color, the output is using surface

Card is black, no output

Card is showing back material, output is volume

Everything was plugged into the surface input. It's like the input of the output node was getting confused or something.

@Philipp Oeser (lichtwerk)

Indeed -- just like @Zachary (AFWS) says -- it happens randomly.

Sometimes when I'm just switching between views (or even just moving the camera in the viewport), and other times when I'm switching between viewport shading options.
It actually crashes when I repeatedly try to change the material back and forth between the default gray material (after importing the model) and the material it's supposed to be.
This only seems to happen with image-based materials (so far).

If you play around with the model I specified (and viewport shading or overlay options), it will happen, but it takes time for it to appear, and it mainly seems to do it after switching from Layout to other tabs or accessing the Overlay menu or after changing the rendering method in the viewport.

Maybe this is related to why the material seems to be confused:

I have ensured all materials are opaque after import, but exporting them seems to save them as partially-transparent in FBX format.

Cannot reproduce here.
Also please be more specific what you mean by:

  • "second material" [which is the 'second']?
  • "swapping between linked materials/textures"

To sum it up: we need a reproducable case (with exact steps to achieve this) to be able to investigate this.
Marking as incomplete until required information is given...

Doing the things I've mentioned (including things in the paragraphs) long enough will reproduce the issue.

I've had this happen on only a single mesh -- the eye mesh + material (while the other mesh appears normally) -- After that happened, it quit happening to one mesh and continuously turned both black simultaneously. I'm not sure if it has something to do with what was selected in the UV Editor mode at that time or not, but it could be related.

Again, after the material turns black, the subsequent crash that happens only happens upon repeatedly (and randomly) swapping the image or material used for the material back and forth to the default material (or the alternate texture) repeatedly in the dropdown GUI in an attempt to get the image texture to reappear, bringing it back from black. I can *sometimes* get it back when reimporting the image from an external file.

Maybe @Zachary (AFWS) can offer more information on how/when this happens in a multi-model setup? -- It seems he's using image-based materials as well...

This is the only genuinely "reproducible" part, but I can assure you that working with the model for a decent period of time in the ways that I mentioned will reproduce the black material issue at some point -- but, again, as @Zachary (AFWS) has pointed out, this only happens at random times, and I haven't found a way to reliably invoke this behavior (aside from working with a model without ever modifying its geometry aside from scale.)

The "second" material is just the alternate material, since the model I specified has 2 image-based materials associated with it upon importing from the .DAE file.

@Zachary (AFWS) -- Also, did you import your modes from the .dae extension at any point? And do they have bones associated with them? -- I would like to rule out whether this material issue is from the import process, the models themselves, or the materials (and/or viewport rendering) only. Maybe it happens only after export to FBX?

@AwesomeData (awesomedata)
Everything was done inside Blender ,so I don't think it has anything to do with the .dae. Looks like there's another bug report about this https://developer.blender.org/T60214 Even following those steps, I couldn't get it to happen. Maybe it was a bug that got fixed?

It definitely didn't get fixed -- I got it last night (in the daily build) when pressing the scale shortcut with a light selected. Playing with the armature was what I was doing right before I scaled it.

@Zachary (AFWS)
Do your card models have any bones/armatures by any chance?

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 15 2019, 1:20 PM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Is this still an issue?

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

I think quite a few bugs related to materials turning black have been fixed, so this is hopefully fixed.

If you still have either of the issues, I'd recommend submitting a fresh report following Philip's advice and the general guidelines: ONE issue per report. The material thing and the exporting thing don't sound related to me, and it makes this report a mess to understand and follow.