Page MenuHome

OBJ file isn't importing
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 1803
Graphics card: Vega 10 (2700U APU)

Blender Version
Broken: 2.79b, Date: 2018-03-22 14:10, Hash: f4dc9f9d68b
Worked: Well, this is the only version I've used

Short description of error
So I was trying to import an obj file that I exported from Tinkercad, and it kept making Blender throw up an error. I tried searching it, and I found someone saying that it had to do with protected folders, so I moved it to my Desktop. Still no dice.

The error that came up for me was:

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\addons\io_scene_obj\__init__.py", line 148, in execute
    return import_obj.load(context, **keywords)
  File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\addons\io_scene_obj\import_obj.py", line 1261, in load
    unique_material_images, use_image_search, use_cycles, float_func)
  File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\addons\io_scene_obj\import_obj.py", line 429, in create_materials
    illum = int(line_split[1])
ValueError: invalid literal for int() with base 10: b'0.0'

location: <unknown location>:-1

Exact steps for others to reproduce the error
You just need to go through the normal import steps: Files, Import, click Waveform (.obj), and then go the location of the downloaded obj file, and try to import it.

Details

Type
Bug

Event Timeline

Sorry, don't use that .obj file, use this one. I made a change to that one that had the line: b 0 0 0 because I thought that it was asking for base coordinates in the error message

Campbell Barton (campbellbarton) closed this task as Resolved.

This is fixed in master & blender2.7 branches.