Page MenuHome

Cursor random rotation
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: Geforce 1080

Blender Version
Broken:
Date: 2019-01-04 00:26
Hash: c97c76c01c1d
Branch: blender2.7

Short description of error
The cursor gets randomly rotated in the viewport

Exact steps for others to reproduce the error
Just click anywhere in the viewport to position the cursor and it gets a weird rotation.

Details

Type
Bug

Event Timeline

Dalai Felinto (dfelinto) closed this task as Invalid.

Not really random, and the result you get from factory startup is different than what you report. I believe it is working as intended, so I'm closing the report for now. If you believe a bug is still around please attach a sample .blend (and let us know if you are setting the cursor via the left mouse button or the cursor tool).

That said, @Campbell Barton (campbellbarton) / @William Reynish (billrey) I have a few suggestions to the 3d cursor tool that may help users to not get confused in the future:

  • Orientation "None" sounds misleading to me, I would expect that to be a 0,0,0 orientation.
  • I would instead have None as a 0,0,0 and add a new one called Previous, that would behave as None now.
Zachary (AFWS) added a subscriber: Zachary (AFWS).EditedJan 4 2019, 3:57 PM
  • Orientation "None" sounds misleading to me, I would expect that to be a 0,0,0 orientation.
  • I would instead have None as a 0,0,0 and add a new one called Previous, that would behave as None now.

The rotation at first kinda confused me too. Is "None" suppose to be 0,0,0? If it's rotated and then you set it to None, it stays rotated. It's always a pain to try to get it reset back to 0,0,0.

@Zachary (AFWS) None as it is now is supposed to "Leave orientation unchanged", as per its tooltip.