Page MenuHome

Blender 2.8: Saving Armature very often ends in possibly broken .blend files
Closed, ArchivedPublic

Description

System Information
Operating system: Win 10 Pro Build V1803 Build 17134.472
Graphics card: GTX 1080 Ti
CPU: i7 6-core 3.7 GHz Unlocked

Blender Version
Broken: All latest Blender 2.8 versions (up to the one I just downloaded (06. January 2019)) (latest = the last couple of weeks, this always happened, I used several different 2.8 builds, always downloading the latest in hope that this has been fixed)
Worked: Blender 2.79

Short description of error
I am not sure what exactly causes this yet. But saving a project containing armature as .blend file can cause Blender to crash/close immediately when trying to open the saved .blend file again later on.
I am not sure, it could be the naming. Most of the time this started happening was when i renamed the bones (it really could be some other reason). Normally the first few saved files when starting on the armature can be loaded without problem (if there's mesh around or not). But after a certain time the saved files are like broken, or there's a bug in blender that crashes blender on opening the file.
I have attached two blend files. makeMyArmature.blend was created in Blender 2.79. I then opened the file in blender 2.8 (without ANY problems) and removed the rotation constraints from the index fingers and saved the file as makeMyArmature28.blend. Trying to open the file in Blender 2.8 afterwards (via File menu (no matter what option ("recent files" or just "open")) makes Blender close immediately.
Just ran "blender.exe -d" and got the following error:

Read blend: D:\Blender\makeMyArmature28.blend
read file D:\Blender\makeMyArmature28.blend
Version 280 sub 40 date 2019-01-05 20:52 hash 4b7596ec914e
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF7AF541654
Module : C:\Program Files\Blender Foundation\Blender28\blender.exe

Exact steps for others to reproduce the error
I cannot say, as it seems to happen randomly. Maybe it has to do with renaming bones, but I really cannot tell.

Steps I took regarding the attached blend files:

  1. opened the makeMyArmature.blend file from 2.79 in Blender 2.8
  2. changed something on the armature (as said, in my case I removed all the copy rotation constraints on both index fingers)
  3. saved the file as makeMyArmature28.blend
  4. closed blender
  5. open the new saved file and blender crashes immediately

x. I tried to redo this several times, didn't work!

This (not being able to open a saved file with armature in it) happened a huge amount of times, actually so often that I had to go back to Blender 2.79 for working with armature even though I really didn't want to ;) Even though I couldn't reproduce upper mentioned steps. Haven't had this problem with non-armature-containing files yet.

I tried to redo the exact same steps, and the blend file was fine when opening it again, so it's really very random. I tried removing the index finger constraints, I tried renaming and moving bones, but the saved file always was "openable" by Blender again.
I tried doing everything to reproduce the error, no chance so far, not by renaming, not by removing constraints, but what is funny is that after removing the index finger constraints I couldn't add a new constraints to b.finger.index.last.L that copies the rotation from b.finger.index.middle.L by adding the constraint manually (without ctrl-shift-c) and then selecting the armature and the bone. I see the bones list, but when I choose b.finger.index.middle.L, it just doesn't set it. There's still a lot of bugs with armature. THANK YOU VERY MUCH FOR ALL YOUR HARD FANTASTIC WORK!!!!! <3

Details

Type
Bug

Event Timeline

Oli Gerber (oliiix) renamed this task from Saving Armature very often ends in possibly broken .blend files to Blender 2.8: Saving Armature very often ends in possibly broken .blend files.

It's not happening anymore on recent releases so far. I will update this task if I find out more. Please do not waste any efforts on this unless you hear from me again, it might be fixed.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Since a week passed, I'll assume this is not a bug anymore. Otherwise we can reopen the report.

Probably the .blend file was not broken, but rather some issue in loading or drawing caused a crash.