Page MenuHome

Cycles - No viewport rendering update, when changing shader parameters in World Texture Group Node
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 x64
Graphics card: Geforece 1080Ti

Blender Version
Broken: 2.80, 96f762500ef9, 2018-01-07, as found on the splash screen)

Short description of error
Cycles - No viewport rendering update, when changing shader parameters in World Texture Group Node

Exact steps for others to reproduce the error
Open the attached *.blend file.
In the 3D-viewport activate viewport rendering.
In the compositing view on the bottom change the Sky_Strength attribute of the Sky_Sun_Control group node to 0. Nothing happens.
In the Properties on the right switch form Sky_001 to World and back. Now you see the effect of the Sky_Strength attribute change.

Event Timeline

I just created another Blender Scene with an simpler world node setup.


Open the Scene
Click the Viewport render icon.
Change the strength in the Background node in the shading tab.
In the properties Tab switch from Studio_052 to Studio_053.
Change the strength in the Background node in the shading tab. Nothing happens. Cycles is not updating.

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

I can't reproduce this problem with either .blend file.

Does it still happen after loading factory settings?

I tried it also on another computer with fresh user settings and reseted to factory defaults. The problem is still there.
It is strange, the viewport update works if Studio_052 is set as World, but if you switch to Studio_053 as World the viewport update isn´t working.
There is only an update once in Studio_053 World when you switch from Studio_052 to it. But once Studio_053 is set, changing for example the strength or rotating in the Mapping Node, has no effect at all.
I tried as described above.

Open the Scene World_HDR.blend
Click the Viewport render icon.
Change the strength in the Background node in the shading tab to 0. The Viewport rendering is updated.
In the properties World tab switch from Studio_052 to Studio_053. The Viewport rendering is updated.
Now change the strength in the Background node in the Shader Editor to 0. Nothing happens. Cycles is not updating.
In the properties World tab switch from Studio_053 to Studio_052 and back to Studio_053. Now the Viewport shows the correct result.
Now you can try to change the strength in the Background node in the Shader Editor to 1. No Viewport Update. Try to Z-rotate in the mapping node. No Update.

I tested yet another file.

It seems that only one World is working correctly. When switching to another World and trying to adjust Parameters there is no cycles viewport update.

Open Blender Scene.
Activate Viewport rendering


Change the Background_Strength in the Sky_Sun_Control node in the Shader Editor to 0. The Viewport rendering is updated.
In the properties World tab switch from Sky_001 to Sky_002. The Viewport rendering is updated.
Change the Background_Strength in the Sky_Sun_Control node in the Shader Editor to 0. The Viewport rendering isn´t updated.

Only changes in Sky_001 World is updated in the viewport!

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, Medium.Jan 10 2019, 7:47 PM