Page MenuHome

Sculpt mode - Stroke method shortcut gives an error
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX970

Blender Version
Broken:
blender-2.80-91a155833e59

Short description of error

Stroke method shortcut E doesn't display menu in Sculpt Mode and just gives an error:

Traceback (most recent call last):

File "C:\blender28\2.80\scripts\startup\bl_operators\wm.py", line 526, in execute
  value = context_path_validate(context, data_path)
File "C:\blender28\2.80\scripts\startup\bl_operators\wm.py", line 79, in context_path_validate
  value = eval("context.%s" % data_path) if data_path else Ellipsis
File "<string>", line 1, in <module>

AttributeError: 'Brush' object has no attribute 'stroke_texture'

location: <unknown location>:-1

Absolutely identical to T39412

Exact steps for others to reproduce the error

  1. Select any object and switch to Sculpt Mode
  2. Press E

Details

Type
Bug

Event Timeline

I cannot reproduce this. Not with the build you mentioned, not with the latest HEAD.
How are you "switching" to sculpt mode? via the workspace or via tab?

Also, did you run with --factory-startup?
I can't even find the string 'stroke_texture' anywhere in the code.

I cannot reproduce this. Not with the build you mentioned, not with the latest HEAD.
How are you "switching" to sculpt mode? via the workspace or via tab?

Also, did you run with --factory-startup?
I can't even find the string 'stroke_texture' anywhere in the code.

Hm, interesting. I tried to delete configs and it worked ok anew. Deleting folder by folder I found out that issue is present only with the attached userpref.blend and startup.blend

Maybe it'll be helpful.

Philipp Oeser (lichtwerk) closed this task as Archived.Wed, Jan 9, 9:38 AM
Philipp Oeser (lichtwerk) claimed this task.

If this is working fine with --factory-startup and only causes an error with (outdated) preferences then this can not be considered a bug, I'm afraid...

Closing (but feel free if issues persist when you updated your preferences...)