Page MenuHome

Tooltips error when using custom keymaps
Closed, ArchivedPublic

Description

System Information
Win 10

Blender Version
Broken: blender-2.80-91a155833e59-win64

Short description of error
Some Tooltips gives the "internal error!" when using custom keymaps. Also some info disappears.

Measure tool example.
Before:

After:

Exact steps for others to reproduce the error
Launch Blender, go to Edit / Preferences / Keymap section / Export the keymap configuration. Now import that same keymap you just exported and that error will happen.

Also a side effect of using a custom keymap is that the preferences section inside the keymap tab also disappears.

Here before:

After:

Details

Type
Bug

Event Timeline

Fixed Internal Error rBdf8e8e5b6be91c09e873f9770ea08002b2c45216 showing up, the issue with the missing keymap remains.

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.Jan 9 2019, 10:07 AM
Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Custom keymaps are intended not to have any preferences, we can only reliably make such global changes to the builtin keymaps. Once you have a custom keymap all those settings are baked in.

@Brecht Van Lommel (brecht) Thanks for the clarification. But this intended behavior is a little tough to deal with. For example if I want to upgrade my keymap by changing some preference, I'd have to build everything from scratch. Quite painful.