Page MenuHome

project left in texture paint mode brings pink object after open
Closed, ResolvedPublic

Description

Windows 10 Pro 64bit, AMD Ryzen 5 2600, 16Gb RAM
NVidia GTX 1060 6Gb

Windows 10 Pro 64bit, AMD Ryzen 5 1600, 8Gb RAM
NVidia GTX 1050Ti 4 Gb

Blender 2.8 Beta 91a155833e59

If you save your project leaving with a texture paint window / lookdev, you get pink object after reloading that.

Steps: Create a plane, unwrap, assign a shader, connect an image texture to, create a new image, paint into the image, save that image, save file. After reload you get it pink until you select the texture slot or switch to another viewport mode (solid, wireframe, rendered).

Details

Type
Bug

Event Timeline

Should be something with the overlays, as if they are turned off, project saved, the object is fine when reloaded.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Jan 25 2019, 2:03 PM

I can not reproduce this. I think this was solved recently.

Could you retry with the latest blender beta?

If I open the attached test1.blend in Blender 2.8 3d8cbb534f82, the plane is pink. If you select the only texture slot or you switch from lookdev to anything else it gets black as intended. If you do nothing, you can still paint (changes appear in the image editor window) but the plane is still pink.

Sebastian Parborg (zeddb) closed this task as Resolved.Jan 25 2019, 2:50 PM
Sebastian Parborg (zeddb) claimed this task.

This was already fixed: https://developer.blender.org/rB05ebdc2b71ab45024467faf40897ebd2707a0d5c

That commit didn't make it into todays build. But it should be in tomorrow.