Page MenuHome

Keyframes on Cut-ted strips
Closed, DuplicatePublic

Description

System Information
Operating system: Ubuntu 18.04.1 LTS

Blender Version
Broken: 95736683a96d33a8a7220788502250fa9e109132

Short description of error
When cutting a meta strip, the F-curves linked to the strips inside the meta are copied, but the property indicators for the right meta-strip do not update until a keyframe is added/changed

Exact steps for others to reproduce the error

  • Open a new "Video Editing" file
  • Add a "color" strip
  • Set two keyframes to the "opacity" property of this strip (example : at frame 1, opacity=1, at frame 25 opacity=0)
  • Soft-cut this strip at frame 15 (K)
  • Open a graph editor, and see that the F-curve has correctly been duplicated by selecting the two halves one after the other
  • Select the first half, in the properties panel, watch the "Opacity" value as you scrub over the first half. The opacity changes as expected
  • Select the second half, in the properties pane, watch the "Opacity" value as you scrub over the second half. The opacity does not change
  • With the second strip selected, in the graph editor, select and move a keyframe, but cancel the move by hitting ESC or right-mouse. Now the opacity changes as expected when scrubbing

Event Timeline

I can somewhat reproduce something that feels wrong, but not exactly what you describe..

Can you prepare a .blend file that makes it easier for us to reproduce the issue you are experiencing?

Sorry about that, it looks like I introduced this bug in my local build by applying a patch I made to solve this bug : T60194

I believe the weirdness you are seeing is the bug above ?

Should I close this task, or move it as a sub-task of T60194 ?

Actually it looked like in my case the problematic sequence was the left one. However maybe I just don't know what I'm doing when using the VSE :D
If you think it is the same, then close this task.

This is actually caused by the exact same issue as T60194. Fix incoming.