Page MenuHome

Error with custom nodes and node editor
Closed, InvalidPublic

Description

possibly related to T60382.

When I view the node editor with appleseed as the render engine, all my nodes appear in the add list:

When I try to add a node, I get this:

Traceback (most recent call last):
  File "d:\blender-git\blender28\bin\Release\2.80\scripts\startup\bl_operators\node.py", line 131, in invoke
    result = self.execute(context)
  File "d:\blender-git\blender28\bin\Release\2.80\scripts\startup\bl_operators\node.py", line 122, in execute
    self.create_node(context)
  File "d:\blender-git\blender28\bin\Release\2.80\scripts\startup\bl_operators\node.py", line 92, in create_node
    node = tree.nodes.new(type=node_type)
RuntimeError: Error: Cannot add node of type AppleseedasBlackbodyNode to node tree 'Material_tree'

No other details are provided. So I have no idea why the error is occurring or how to fix it.

For the sake of completeness, I've attached the full terminal log plus the Python file we use for creating the nodes and node tree.

Details

Type
Bug

Event Timeline

Havent look in depth, but the AppleseedOSLNode polls for AppleseedNodeTree whereas the nodetree itself is called AppleseedOSLNodeTree, could this be the cause?

Besides that it would be helpful when you try to remove everything from the file that is not necessary to reproduce the bug.
Also currently the script you provided does not run on its own, which makes it hard to reproduce the issue.

Jonathan Dent (jdent02) closed this task as Invalid.Thu, Jan 10, 1:49 PM
Jonathan Dent (jdent02) claimed this task.

Good Lord that's embarrassing, must've been doing stuff too late into the evening.

Philipp, you are correct.