Page MenuHome

Weird behavior with texture and brush
Closed, InvalidPublic

Description

System Information
Operating system: macOS High Sierra
Graphics card:
NVIDIA GeForce GT 650M 1024 Mo
Intel HD Graphics 4000 1536 Mo

Blender Version
Broken: lender Version 2.80 Beta
Date : 2019-01-04 13:30
Hash : 2c21e3e35f30

Hi. I think I've discovered a weird behavior that I cannot reproduce in the older version(2.79). I tried to paint some normal map on a cube with a texture. I don't understand why the color of the brush still affect the texture since a image is added on the brush. I cannot have only the texture image as a brush.

After a few Minutes of test, I tried to change the color of the brush and I saw that the color is mixed with the texture.

As you can see on the image bellow, I have a normal map texture : A stitch. I cannot merge the stitch with the background color because of this issue.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.Jan 14 2019, 4:46 AM

Please attach a simple .blend file to reproduce the problem, with textures packed if necessary. It's difficult to guess how exactly things were set up in this file.

Camille (Ekiwnox) added a comment.EditedJan 14 2019, 8:21 PM

Here's a file with the same issue. I basically did a file with a normal map texture that I use as a brush.
You will see that the color of the brush still affect the brush even there's an image. Even if I select the color of the normal map (the pastel purple) it's wrong with the normal map texture. But if I change de brush and I put only a basic brush without texture and I select the same colors, it blends perfectly --'.

I also tried to change the blend mode in the paint brush, but nothing worked.
Maybe I'm doing something wrong ! Let me know :-)

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 7 2019, 2:52 PM
Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

This was also the case in 2.79 (brush color was also multiplied by brush texture)

Just set the brush color to pure white and the applied colors will represent exactly what is in the brush texture...

Dont see a bug here [unless @Brecht Van Lommel (brecht) has objections?], closing... (feel free to comment again if issues persist)