Page MenuHome

Blender 2.80 crash when creating movie file from image sequence
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: AMD Radeon R9 200 Series

Blender Version
Broken:
2.80, 2edd32c168d3, blender2.8, 2019-01-06 and also on 2826c2be545e, blender 2.8, 2019-01-12

When trying to create a movie file from an image sequence in the sequencer, blender crashes a short while after clicking the Render Animation button making only a few frames.

Exact steps for others to reproduce the error
After adding the image sequence and adjusted the end image number from 250 to 674, I Selected HDTV1080p preset and the file format to FFmpeg video with container MPEG-4. I tried this on both of the 2.80 releases above and both crashed several times after advancing a few frames. The native image sizes are 4000x3000 pixels and jpg format with 72dpi.
Then I tried the same in blender 2.79b and that managed to create the video file from the image sequence with the same settings.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

We need an example .blend file to reproduce the problem.

This is one of the actual files I tried to use. I created several because I thought that I messed up something with the setup but all resulted with the crash.

I have the same problem, in my case its a bit smaller image sequence. I set my system to use Matroska and H.264 codec, my PC has an ATI Radeon RX 580 GPU with 8GB of RAM, I have the system set to use OpenCL with both GPU and CPU checked, some times it crashes at the begin other times it goes up to frame 26 before crashing. My PC has 32GB of RAM, and the CPU is an AMD FX-8320 running Windows 10 Home. The PNG images sequence I can render no problem but when I try to use them to create a video file the sBlender crashes.

My Blender version is the 2.80.42

I'll attach to this messages the files that I'm having problem. And a question will it be possible to use the 2.79 version to get the images into a video file while this issue/bug with 2.80 version keep happening?

The idea of using the old 2.79 video sequence editor to render the images sequence worked for me, I know it is not ideal, and we should be able to completely use 100% of ll fatures of the 2.8 version, but until this issue is fixed I suggest using the same method that I did, using the 2.79 just to create the video file, while the 2.80 render the frames into images

At the moment I use V2.79b to create the video from the images, the build 2019-02-05 still crashes. It does not matter where the render device is set, CPU, Open CL, graphics card or video card+CPU, it will crash. Not sure if video encoding utilizes the video card anyways. I have 4GB of VRAM on the ASUS R9 290X DirectCU II OC and 32 GB RAM, Intel i7-4790K CPU @ 4Ghz with windows 10.

Could it be that this is a problem with the Radeon GPU family? Mine is an RX 580, Andrew's is an R9, both cards are from Radeon tech, so it starts to point in that direction, that perhaps there are one or more code lines used by the developers that are more CUDA friendly (NVidia GPU) but at the same tie the OpenCL has problem with it.

Please correct me if I am doing this wrong:

  • create new image sequence 0.jpg - 100.jpg
  • click on panel->srtip->change data files
  • select 0.jpg - 300.jpg
  • change strip->length to 300
  • click render->render animation

in my case no crash...
GPU should not play role here, but I can not tell for sure.

Can you run blender from command line with -d argument to see if a crash report or some message pointing to problem is generated?

Could you plese show in more details? (screen capture) because I'm having trouble following your steps Richard.

BTW here it is the console response when the video file render crashed

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF601CC81A6

Please provide a complete example with all required files and steps to reproduce this issue.

I have 2 files one dealing with the camera movement in a scene ->

When rendering the animation video file (PNG image sequence to FFMPEG video file) it crashes and in the command prompt window appear the following Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF6D87B81A6

The other is an Animation using a few empty objects, primitives and the array modifier ->

with this file the following message appear when the system crashes

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF6D87B81A6

As you can see it's the same message for both

seems like the image sequences are missing?

Just for the sake of more testing, with V2.80 build 2019-02-08 I transferred all the same image files, that crashed on my desktop, to my laptop which has a CUDA but not supported by Blender 2.80. I did not import the 2.79b version settings. The video was created without crash. Now I go back to my desktop and download this same latest build and will test it again.

Well, this is interesting. I downloaded the same build, the one I just downloaded to my laptop for testing, and on my desktop the daily build Blender V2.8 is crashing upon opening so I cannot even test if this version would work with that image sequence file. A build from a couple of days ago, build 2019-02-05, was opening regularly and I used it normally for other work.
As another test, I have Blender V2.80 version with integrated Mantaflow as well and that worked with the same V2.80 video sequence file where the daily build crashed all the time. The Mantaflow integrated blender is rather old one though.

This may imply that the Radeon GPU family may not be the problem otherwise the older V2.80 with Mantaflow would not work either and that uses exact the same preference settings as the daily build.

If you guys need the image sequence here it it the image sequence of my array animation, if you wish the House Scene image sequence and try to create the video file base on them, just ask and I'll supply them.

This morning I downloaded the latest build of V2.80 and this time it started without crash but when tried to run the image sequence file it crashed just like before.

Does this file crash on your system(s)?


(Nothing special; trying to standardise on a test file)

If so,... (or if not, then on a file that does, also zipping the file in the same way I have)

  • Run Blender with --debug
  • You Can do this by:
    1. Finding where blender.exe is
    2. On the white space, whilst holding shift, right click and select Open Command Windows here
    3. Drag blender.exe in to the command window
    4. add --debug and hit enter

Save the log as a text file and upload it. Do not paste it in the comments.

@ALESSANDRO NASCIMENTO MILHIOLO (alessandromilhiolo) You can delete the images in T60460#616503 as there's no easy way to download them and gives us RSI in our scroll finger:)

@Andrew Sprok (sprad001)
Can you please confirm my earlier comment, that I am following the steps required to reproduce crash?

@ALESSANDRO NASCIMENTO MILHIOLO (alessandromilhiolo)

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF6D87B81A6

This unfortunately did not tell me too much.

I downloaded those images using httrack, then was probably banned for doing so :D
But still it's ~170MB so I would remove them now.

Still no crash on my system.
Starting to think about externalities, such as limited access to output path, no free space on disk or so. I heard, that some of those cases may not be handled in Blender and it would crash.

@Christopher_Anderssarian
Can you reproduce the crash?
Your file was also rendered without problem

@Christopher_Anderssarian
Can you reproduce the crash?
Your file was also rendered without problem

No crash, on the uploaded file. But tried to with the same setting as described.

Starting to think about externalities....

Me thinks so too... Awaiting debug output...

I downloaded the 'Image Sequence Rendering' file. I moved it to a drive where there is plenty of space to eliminate possible problem with that, as previous messages suggest.
Followed Christopher's instructions and before running the render I changed the output folder. Initially I forgot to do that and got the message 'Could not open file for writing', of course because based on the test file it was trying to write to a drive that was not activated on my computer. That was R: drive.

Unfortunately Blender crashed and gave an Access violation error, just like Alessandro had but with a different address.

Here is the attached result. The LibreOffice file should open in Word as well.

I forgot to mention that the trace file mentions a problem with some file 'uv_magic_uv' and triggered the Notepad application to automatically open it. I saved it and attach it also. Not sure why this gets activated when rendering a video.

Here is the attached result. The LibreOffice file should open in Word as well.

Plaintext is preferabe :)

This uv_magic_uv is due to a addon you have enabled. But having said that, Can you try again running blender with arguments -d --factory-startup

I ran the test with the above arguments and it did not crash. It finished creating the mp4 file.

I also ran my own file that always crashed before and that generated the video too, but only with the --factory-startup argument.

Here is the output of that test

This means, that there is something wrong with your user preferences.

We can investigate this, but will need this userpref.blend file. In your case it's located in
C:\Users\Andy\AppData\Roaming\Blender Foundation\Blender\2.80\config\

Guys after thinking for a while I got the feeling that the problem may be with the Windows folder security system. I download and completely replaced the Blender 2.8 folder (Delete old one put new one in place), then I did go to folder properties in the security tab, and noticed that the following items were set with read / write only

(I translate it from portuguese since my system is set on Portuguese)

  • All applications and packages
  • All packages and restrict applications
  • My own user account
  • Administrator accounts
  • User accounts

Since I'm the only one with access to my computer I did set all of the above settings to Full Control, after that I did try it once more and am happy to say that Blender 2.80.44 rendered all PNG image sequence, as well as rendered the video file without the need of external software or older Blender version.

So perhaps the true problem lies with the fact that we're just unpacking Blender folder and running it without checking the folder security and ownership manually. When we install Blender from an installer/setup file, the setup will set the folder security automatically, but since we do not have an installer we need to set it manually

Well it did render a new file and then the video file

I'm still trying to see the differences between them, but this last one did render completely in the 2.8 version

@Alessandro Caragnini (alessandro) NASCIMENTO MILHIOLO (alessandromilhiolo) I download dailies frequently because they fix one thing and mess up something else. At the moment I do not find the left click setting that used to be in Preferences. Startup screen only shows it at first run which in this case was okay because I removed the blender config file and that forced blender to create a new one and at the same time I could set left click, on 2.80 I am used to that. That is actually how I got it to create the image sequence movie with my own old file that was crashing all the time and I did not change anything in the security settings. The config setting should be already set with the correct permissions because I have 2.79b installed and the config file resides there but in its 2.80 folder.

@Richard Antalik (ISS), Which brings me to the 2.80 config file that I attached. Under these it used to crash with the image sequence video creation.

As I was typing Richard's ID it did add a subscriber, I thought if I remove the message then it will disappear but apparently not. How you you remove people in this case?

What are the findings from my userpref.blend file?

Sorry it's a no deal. And it seems that my blender worked fine just once, right after installing it and configuring it. As soon as the system shutdown / started once more (Some time later) the EXCEPTION_ACCESS_VIOLATION error had come back. I even used the userpref.blend that Andrew offered to use, but no deal.

I'll erase my Blender 2.8 folder and paste a new version in place. If the error persist then it might be some sort of old config record left somewhere in the system registry. I tell thins under the assumption that the access violation is dealing with an system address or memory address

Alessandro, just remove the userpref.blend file for the C:\Users\....\AppData\Roaming\Blender Foundation\Blender\2.80\config\ folder and see if it starts to work. Do not activate any addons to see if it will work.

@ALESSANDRO NASCIMENTO MILHIOLO (alessandromilhiolo)
Not sure if Blender does use windows registry, as it's not portable approach. My bet would be, that it doesn't.
Have you tried running blender with --factory-startup parameter? Or you can do, what @Andrew Sprok (sprad001) suggested in last comment

I tried to use userpref.blend file provided by @Andrew Sprok (sprad001). Still can not reproduce this issue.

Not sure if Blender does use windows registry, as it's not portable approach. My bet would be, that it doesn't.

Yes no half, it uses the registry for .blend file integration with the windows explorer (since it's the only way to do that), but blender stores none of its settings in it.

@ALESSANDRO NASCIMENTO MILHIOLO (alessandromilhiolo)
Not sure if Blender does use windows registry, as it's not portable approach. My bet would be, that it doesn't.
Have you tried running blender with --factory-startup parameter? Or you can do, what @Andrew Sprok (sprad001) suggested in last comment
I tried to use userpref.blend file provided by @Andrew Sprok (sprad001). Still can not reproduce this issue.

I don't want to be too optimistic and start the victory dance, but it seems that this small change that I did add to the Blender shortcut on my Desktop workspace did the trick, I tested with all recent animation files and all of them rendered and created the video file. I'll be testing it further to be sure of it.

For those with the same problem as me just follow @Richard Antalik (ISS) sugestion and add

--factory-startup

Right after the program call, i.e.:

"C:\Program Files\Blender Foundation\blender-2.80.0-git.69b2f5268114-windows64\blender.exe" --factory-startup

@ALESSANDRO NASCIMENTO MILHIOLO (alessandromilhiolo) the only problem with that is, every time you download a new build you need to add the --factory-startup. By deleting the userpref.blend file all is solved. It creates a new blank one and it is done. Well, not exactly because you need to activate some of the add-ons and setup you Preferences but you only need to do it once. Since I deleted that file, I used another 5 or 6 daily builds and all run ok and create video from image sequences.

Richard Antalik (ISS) closed this task as Resolved.Feb 22 2019, 9:22 AM
Richard Antalik (ISS) claimed this task.

the only problem with that is, every time you download a new build you need to add the --factory-startup

This shouldn't be the case

It may be possible, that version of userpref.blend needs to be bumped due to changes in code. This is done by internal automated process that may corrupt the file, not totally sure with this, I have never seen such code.

In any case, seems like the solution is known, so I will close this.