Page MenuHome

Unable to select vertices on right side of model
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 8.1
Graphics card: AMD Radeon HD 8400 / R3 Series

Blender Version
Broken: 2.80, 2826c2be545e, 2019-01-12

Short description of error
I am unable to select vertices on the right side of the model in edit mode. This happens for nearly all .blend files I open, and in one instance, Blender crashed when I tried to select a vertex on the right side. The only way I could select these vertices is switched the view to X-ray mode.

Exact steps for others to reproduce the error
This began happening as soon as I updated to the current 2.8 beta release.

Details

Type
Bug

Event Timeline

Cant redo:

  • OS: Linux 4.20.0-arch1-1-ARCH
  • REV: 5793a84f1262ce78398320f8518816ff7e62cdd8
  • GPU: GeForce GTX 1080

@Mike (GANONdork123), does the problem still exist when you change the select mode to something else and back? (vertex, edge, face select)

Also is this related to the armature? It seems to be missing in the file you uploaded.

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.Jan 14 2019, 12:09 PM
Mike (GANONdork123) added a comment.EditedJan 14 2019, 9:48 PM

@Jacques Lucke (JacquesLucke) Faces can be selected, but not edges nor vertices. Switching between modes and back does not fix the issue. This issue also occurs regardless of whether the armature and/or the armature modifier is present, as I simply deleted the armature to keep the .blend file as simple as can be. I have discovered that the issue only occurs when I have the "Adjust edit cage to modifier result" enabled in the Subdivision Surface modifier. It seems this is the where the issue lies. This issue seems inconsistent however, as when I create a new .blend project and create a new mesh with said modifier and setting enabled, this issue does not occur. If I append the old mesh from the existing example project however, the issue does occur.

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 15 2019, 12:44 AM
Mike (GANONdork123) added a comment.EditedJan 17 2019, 10:35 PM

I'm new to reporting bugs here, what action should I take? Do I set the priority of the task myself or wait for a developer to assign a priority to the task?

Let devs set priorities methinks.

I think what we do now is wait for someone to be able to reproduce it. Without the ability to reproduce it, there's nothing to fix. I couldn't reproduce with the example blend, Win10 x64 v1607 ad707115d5bc.

Mike (GANONdork123) added a comment.EditedJan 17 2019, 11:35 PM

Ah, I should also mention that by "right" side of the mesh, I mean any vertex on the negative side of the X-axis. I have also been testing each daily build since with no luck, both 32-bit and 64-bit Windows versions.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Jan 28 2019, 2:33 PM

Is there any difference if you tick OpenGL depth picking in the Viewport -> Selection preferences?
Does this happen in the latest 2.79 build on https://builder.blender.org/download/ ?

If not could you see if you can reproduce this if you change the selection preferences settings in 2.79?

@Sebastian Parborg (zeddb)

enabling OpenGL depth picking does not seem to make a difference. I've also discovered that the issue does not seem to occur in 2.8 Beta builds for Linux.

The issue does not occur in the latest 2.79 build. Seems to be exclusively a 2.8 issue.

I guess that means this is a driver issue then. The 8000 series hasn't been supported in a while so this is unlikely to be fixed on windows.
@Clément Foucault (fclem) is this one of this "if the user finds a easy fix, we will include it, otherwise we can really fix this" bug?

{F6601478}Hoping this will help :
If I save a simple a blend file (default cube subdivided in 10 cuts) using blender 2.80.44 (hash 69b2f5268114), I cannot select all vertices even if I open the file with blender 2.80.39 (hash : d96596de294e) (see attached file bug_version_2.80.44.blend)
If I create an identical blend file (the same subdivided default cube) using blender 2.80.39 (hash : d96596de294e), I can select all vertices I want with this version, but if I open this file with the 2.80.44 (hash 69b2f5268114) version, the issue occurs again (see attached file NoBug_version_2.80.39.blend)

I can select vertices without problems in the 2.8.44 .blend file.

Can you guys retest if this is still an issue with the latest blender beta? There was a fix recently for selection troubles on older AMD cards:
https://developer.blender.org/rBa1d440de4a3dc7ac3064c4c6df555be238a646c7

Sebastian - Works great…you all are doing a fantastic job...thanks! Regards, Jim

Everything's repaired with last blender beta (hash : c6cbcf83d015) ! No more issue with this version, nice job once again !

(but - for some reason - I still cannot select vertices in the 2.8.44. blend file above mentioned, even when I open it from the last blender beta : but this is of course not a problem)

Thank you, I can still use recent versions of blender with my old PC!

Sebastian Parborg (zeddb) closed this task as Resolved.Feb 14 2019, 4:53 PM
Sebastian Parborg (zeddb) claimed this task.

I'll go a head and close this then as we have 2/3 that has confirmed that it is working.

I can confirm the issue has been resolved for me as well. Sorry for getting back so late.