Page MenuHome

Possible Z-fighting background images using Depth = Both
Closed, ResolvedPublic

Description

System Information
OSX 10.11.6
Intel Iris Pro 1536 MB

Blender Version
2.80, 3c3d80ea22af, 2019-01-08 23:33

Short description of error
It looks like the new method for background images has a small issue when Depth is set to Both. It looks like there is some kind of Z-fighting or normal issue perhaps. It looks like noise, weird effect

Exact steps for others to reproduce the error

  1. Use any scene or new scene as long as there are object in the viewport
  2. Add image as Empty
  3. Use any image and place it around an object or in between
  4. Now hovering the mouse over the image or moving the scene will show a weird noise kind of effect. Sort of like normals or z-fighting
  5. setting Depth to Front or Back solves this "issue"

Ive attached a screengrab of this

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.Jan 14 2019, 10:32 AM

Can't reproduce it on my machine right now. Could you create a .blend file that shows the bug (on your machine)? Make sure to pack the image into the file.

Here is a file


Looks fine when I open it, so it is probably gpu/os related..
Are your drivers up to date?

I dont have supported GPU, nothing to update. See first post for Hardware. Its an Intel Iris Pro.

Is the setting still the same? Thinking about it, why does it show being behind a object, what is default when you can choose front or back??
Is front default or is back default?

I see perhaps the cause now. If i change MultiSample under Preferences > General > OpenCL > MultiSampling from None to 2 or more it gets less noticeable.
But still shows very faint,.

Before

After

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 11 2019, 12:44 PM

This problem doesn't just appear on my mac when I reported it. I just found out that it also appears on the work computer.



System Information
Operating system: Windows 10, Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz 3.40 GHz, 16,0 GM (RAM)
Graphics card: Intel(R) HD Graphics 4600
Blender Version
blender-2.80-936014ea8c74-win64, 2019-03-12
Short description of error
When dragging an image to the ViewPort and placing an object in front of or behind it presents a noise in the image
Exact steps for others to reproduce the error

  1. Start Blender
  2. Drag an image to the viewport
  3. I place a plane or a cube in front or behind and noise appears in the image.

My guess is that the default none. For me it works when i choose front or back. Perhaps this is the issue, the old version had only 2 options, this now has basically 3.

Mac Version: blender-2.80.0-git20190321.9105e1d08467-x86_64 (2019-03-21) work fine for me. Check it up

I used this one, edbf15d3c044, master, 2018-11-28, from Blender and seems to work fine now :)

https://www.dropbox.com/s/w4s8xmgmq7dylsf/Z-fighting-or-normal-issue-ref-images-solved.gif?raw=1

does using the "use alpha" option also work?

Yes, hardly visible due to the blunt Axis colors. But it seems to work.

Not sure why, but looks like Axis colors are slight transparent orso. They are less vibrant than the color input in the Theme panel

Clément Foucault (fclem) closed this task as Resolved.Mar 23 2019, 2:59 AM

Ok the axes are going through but that's a side effect of alpha blending. So main issue is resolved.