Page MenuHome

Grease Pencil hotkeys default when in Continuous Drawing mode
Closed, ArchivedPublic

Description

Blender Version
Broken: 2.79b

Short description of error
I set custom hotkeys for straight line and poly drawing ([Shift]+Left, [Shift]+Right respectively), and they work fine until Continuous Drawing mode is activated.
When in Continuous Drawing mode, the custom hotkeys no longer work, but the default [Ctrl]+Left draws straight lines instead.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) closed this task as Archived.
Antonio Vazquez (antoniov) claimed this task.

When the continuous drawing is enabled, all events are captured by draw module, so no hotkey is captured except the keys defined in this modules (this is the reason why straight lines work). You need finish the continuos before using a new hotkey. This is by design and cannot be changed.

Anyway, I'm not sure what/why are you doing, but in 2.8 all has changed and now the annotations works using tool bar and the drawing is supported with the new GP object, so not sure you will be able to port your ideas to the new version. If you try to create any tool or design a workflow I advice you to switch to 2.8 to work with the new design and tools.

I close this report because isn't a bug.

2.8's Grease Pencil behavior seems to be that way I wanted/expected it to work.

Sadly I can't use it because I'm trying to create an animatic using Grease Pencil and laying out scenes in the Video Sequence Editor, but currently, even an empty scene lags quite bad in VSE in 2.8.

Sadly I can't use it because I'm trying to create an animatic using Grease Pencil and laying out scenes in the Video Sequence Editor, but currently, even an empty scene lags quite bad in VSE in 2.8.

Don't worry, this is being addressed:
D3934: VSE cache with frame prefetching (WIP)
D3597: Add proxy support for all sequences

Oh, nice, I was hoping the problem was known and was being worked on. Thanks for the links!