Page MenuHome

Blender Render scene looks different in view port vs. Video Sequence Editor
Closed, ResolvedPublic

Description

Blender Version
Broken: 2.79b, 2.8 January 30, 01:09:07-a1ae04d15a9f

Short description of error
As the title says. The same scene from the same camera looks different in the view port compared to the scene added to VSE.

Example file:


The top is the VSE preview, the bottom is the viewport.

2.79 - The shading options ("Backface Culling", DoF, AO) seem to be not reflected in the VSE preview, and there doesn't seem to be a way to enable them.

2.80 - Not all shading options seem to be reflected, namely the Backface Culling option.
Additionally, colors just look plainly different between 3D viewport and VSE preview. Uncertain if they're related problems. (This one could be the same problem as T54438)

Details

Type
Bug

Event Timeline

William Reynish (billreynish) triaged this task as Needs Information from User priority.

This is too vague. Can you provide a blend file which immediately demonstrates the issue? We also need exact steps to reproduce.

Thanks.

Okay, including a sample .blend file that should be self-explanatory:

The upper half is VSE, the lower half is BI view port. On the right are the Solidify Modifier, and the two materials I created on Suzanne (For the view port outline effect. One is literally the default material, the other, only change is color to black).
If I turn off the Backface Culling, DoF, and Ambient Occlusion in the view port, the result looks the same. But if I turn them on, the VSE doesn't reflect the changes.

If you need steps to reproduce:

  1. Create elements and camera in the viewport, and enable Backface Culling, DoF, and Ambient Occlusion in the camera (and make sure, like my scene, the elements take advantage of these shading options).
  2. Open up VSE and load the current scene into the timeline.
  3. Change the "Scene Preview/Render" in the strip properties to "Material" so that it's the highest level view port render.

Just an update that when I initially created this task, I hadn't tested on 2.8. I did just now with the latest beta and the problem is still there.
With the same test file above, Eevee actually seems fairly consistent, except for the lack of the backface culling effect (the viewport outline) in VSE (but other viewport effects seem to work, like DoF, AO, Bloom).

Curiously, in 2.8, the LookDev seems to just look different, period:

(Top is VSE, bottom is viewport, both set to "LookDev")

Solid mode is even worse, with VSE just being a silhouette:

*Note: The above screenshots is with the Solidify Modifier on Suzanne removed. With it enabled, Suzanne's just black everywhere (because it seems backface culling is not being respected in VSE viewport).

Richard Antalik (ISS) closed this task as Resolved.Feb 19 2019, 1:14 AM
Richard Antalik (ISS) claimed this task.

Either this is resolved, or can not reproduce
I saw task with similar symptoms, can not find it to mark as duplicate.

Hi, @Richard Antalik (ISS), did you open up the file I attached to check the problem? The issue still remains in 2.79 and also in the latest 2.80.

I've attached it with a short explanation at the bottom of the OP in case it got lost in the comments. You should see a discrepancy between the VSE preview and 3D viewport right away.

Oops, my bad. I thought, that 3D viewport was sequencer preview...

I am not sure if I want to reopen this as I doubt, that this is VSE issue.

You can switch to another view then default (3D view full, animation), and the issue is present here also.

Right, because the default 3D view doesn't have Shading option enabled.

In 2.79:
When you change the top one from VSE to 3D view, it'll default to the 3D viewport without the Shading options enabled.

Turn those on and the 3D views should match.
The VSE preview seems to be showing the viewport as if the Shading options aren't enabled (and there's no way to enable them).

In 2.80:
The issue seems to be bigger. If you change the top VSE to 3D view, this time, you'll notice it still looks different from the VSE preview.
LookDev mode in viewport doesn't look like the LookDev mode in VSE preview, Solid mode in viewport doesn't look like Solid mode in VSE preview.


I don't know if it's a VSE issue at the core, but the visual discrepancy between the VSE preview and 3D viewport is an issue, and that's the point of my bug report.
I guess I could try to create another bug report, but I wouldn't know how to word it differently.

Sorry I am not used to use 3D features of Blender so I know almost nothing about how things should look.
It's hard for me to spot all surface issues as I am used to CAD and "exact" geometry rather then mesh modeling.

I got a bit familiar with view modes And yes they are different even with default cube.
I looked at the modifier on Suzanne and seems that the black surface is caused by flip normals option.

I tried to get somebody look at this on IRC, but without success.
I should rather asked @Brecht Van Lommel (brecht), that I have no clue, what I am doing here...

KiJeon (0o00o0oo) added a comment.EditedFeb 20 2019, 5:08 AM

Oh, no problem, I appreciate you looking into it! And, yes, the black is caused by the flip normals option that I setup intentionally.

Again, the issue here is, as a user, I expect to see what I setup in the 3d viewport to show up in the VSE, or at least be able to make it the same.
The fact that it doesn't currently feels like something that needs to be fixed, but I have no idea if this is a known issue or not.

@Richard Antalik (ISS)

Until @Brecht Van Lommel (brecht) or some other developer can chime in, and since there was no resolution, should this task be reopened?
I don't know how these tasks are organized for visibility for developers, but I'd imagine tasks marked as "Resolved" would not easily be re-reviewed.

Richard Antalik (ISS) reopened this task as Open.Feb 21 2019, 7:58 PM
Richard Antalik (ISS) raised the priority of this task from Needs Information from User to Confirmed, Medium.

Sure, sorry forgot to re-open.

Is this the same issue? T54438: Sequencer Scene preivew Color Management is broken

Task description modified, to correspond to issue.

It might be the same issue as the side note I made regarding clear visual discrepancy between the same rendering modes for the 3D viewport and VSE preview.
However, I'm not convinced it addresses the core problem I began this report with, which seems to be stemming from the VSE preview not displaying shading options like "Backface Culling" from the 3D viewport.

It looks like you deleted the attached .blend for the "example file" when you edited the OP. I revised the edit so hopefully it clearly conveys the issue to whoever needs to review the report.

Thanks for correcting me.

There is also this "feature request" T53158: Video Sequencer Preview should have own engine (and other settings?), that may be relevant.

I will have to seek help with this report, as I will have to determine on which side of codebase there are problems or missing features.

This will take some time until we fix higher priority tasks and some developer familiar with this will be free to assist me.

@Jeroen Bakker (jbakker), can you check if this is fixed in 2.80?

We wouldn't fix this bug in 2.79 anymore.

Just adding that I checked with today's version of Blender 8b2b79c2108b and here are the observations:

  • "Wireframe" mode seems to be same except the background transparency visualization discrepancy.
  • "Solid" modes just look different.
  • "Look Dev" in the VSE preview seems to ignore the viewport altogether but just displays the "Rendered" view.
  • "Rendered" view modes look perfectly the same!

Please note that you have to match the viewport shading options with your render options, otherwise they don't match. Blender cannot detect to what viewport you are looking at.

When you set them up correctly you will see that they will match. For LookDev it uses some defaults as we don't have any place (yet) to change the Look Dev settings.

  • Solid mode

Also note that there the VSE cache does not invalidate when changes happen to these scene settings.

Jeroen Bakker (jbakker) closed this task as Resolved.Jun 7 2019, 8:32 AM

Ah, that's interesting. Can you please point out where the options are for the VSE preview?
I spent a good 20 minutes looking for it to no avail.

Still, I should note that the solid mode still doesn't look exactly the same in your snapshot. Note the visual quality difference for the monkey outline and the edges of cubes, unless this is a settings thing as well.

Blender cannot detect to what viewport you are looking at.

That would actually be a very nice option. It would be quite useful to have all viewports have a generated numerical value the user can select for the VSE preview, that way all necessary settings would be carried over automatically without user input.


Also, should this be marked as "Resolved" if LookDev settings can't be matched? Unless there's a task for it specifically I can't find elsewhere, the issue remains for the LookDev mode. Or should I create a new task for this issue in LookDev?