Page MenuHome

Cylinder without Cap Fill not visible nor selectable in Top Ortho View
Closed, ArchivedPublic

Description

System Information
Operating system: Win7 Home Premium 64-bit, SP1
Graphics card: Nvidia GeForce GTX 750

Blender Version
Broken: 2.80, fc6aac391679, 2019-01-18
Broken: 2.79, 5bd8ac9, 2017-09-11
Worked: (optional)

Short description of error
In Top Ortho View and in Object Mode, Cylinder Meshes without Cap Fill are not viewable
The cylinder cannot be selected, even when pressing "B" to box select.
In 2.79, box selection works, even if cylinder mesh is not seen from the top ortho.

Exact steps for others to reproduce the error

  1. Add a cylinder
  2. Change Cap Fill Type from N-Gon to None
  3. View Scene from the Top Ortho view

See top left - none of the cylinders are shown, Blender 2.80:

Blender 2.79:

Details

Type
Bug

Event Timeline

Dan Rockstreet (DanRockstreet) renamed this task from Cylinder without Cap Fill not visible and selectable in Top Ortho View to Cylinder without Cap Fill not visible nor selectable in Top Ortho View.
William Reynish (billreynish) triaged this task as Confirmed, Medium priority.

@Clément Foucault (fclem): This problem seems to have re-emerged again. I remember we had it earlier on with 2,8, and it's now back. A plane viewed from the side is now also invisible again.

I don't really know if there is still a bug. I note this commit from Clément Foucault as reference: https://developer.blender.org/rBb62d140be9319ec

In this commit there is a note telling : /* This fixes only the biggest case which is a plane in ortho view. */

If we want to see the outlines of the cylinder without cap fill in top ortho view in object mode, applying this:


allows to see the outlines when the object is selected...

However, I have no idea if it can have bad side effects, neither if the current behaviour can be considered as a bug.

there's a similar reported bug here: https://developer.blender.org/T59729 . I don't know if there is a way to merge the 2

Clément Foucault (fclem) closed this task as Archived.Mar 16 2019, 3:28 AM

@Ulysse Martin (youle) Forcing this behavior for all object is costly and will break the visuals for other.

@Dan Rockstreet (DanRockstreet) I did the same setup in 2.79 and cannot select the cylinder even with box select. Only Circle select works and that's because it checks the objects center. The only thing lost is the outline but that's a side effect of the new outlines algorithm and we cannot fix that (see my comment to @Ulysse Martin (youle)).

Thx for your feedback @Clément Foucault (fclem) . Too bad to hear that it's not fixable.
I found a way to view such objects: adding a solidify modifier.