Page MenuHome

Collada: multiple Materials problem
Closed, ResolvedPublic

Description

MacOS 10.14.2
2017
27"
5K

Open Blender 2.80 (January 21, 2019)
I am work to add materials.
'Materials' rename to 'One' is original already there.
Two new one materials
Three new one materials.

One is fire on the floor.
Two is fire on the 4 Walls (not work) collada.
Three is black on the outside wall and below (not work) of collada.

Export: Collada .dae
.dae you can see only texture fire on the floor. Why not work on walls but disappear itself.

Details

Type
Bug

Event Timeline

Seems to work fine here when I import your .dae, see:

  • Does the texture report as missing (File > External Data > Report Missing Files)?
  • Mind sharing a screenshot of yours?
Philipp Oeser (lichtwerk) renamed this task from Materials problem multiply face to Collada: multiple Materials problem.

Did you use Macintosh?

I show you youtube. https://youtu.be/wntTiNXQCgM
Please do it use Macintosh not use Windows.

@Kent Davis (mac4kent): Blender uses the same codebase on the Mac as other platforms. There may be sligt differences caused by differences in GPU's and other things, but Blender is basically the same on Mac, Windows and Linux. For this reason, the platform (Mac) is very unlikely to be the cause of most bugs.

Given that you've posted several bug reports addons, where things that can't be reproduced, even on the Mac, are you sure you are using the latest addons? Are you building Blender yourself - could it be you have forgotten to update the addons folder in that case?

Have you checked importing that .dae back to blender?
(Since you seem to be judging this by inspecting in the MAC filebrowser)

If this is importing back fine into blender, then this might be some limitation of your beloved Operating System instead...

subscribing @Gaia Clary (gaiaclary) here to comment on this (not sure for example if something like T33744 still applies....)

@williams (williams) I already put date (January 21, 2018) I show you youtube https://youtu.be/wntTiNXQCgM
@Philipp Kant (philipp) I did not say import. I say Export.

We talk about Materials:
One can be show (Original).
Two and Three doesn't show

If I remove 'One' on materials then click [+] button add create new 'Four' then export collada .dae whole unable to view texture.

Just one more thing: Have you tried unchecking "Only selected UV Map" under Export Collada Texture Options?

@Philipp Kant (philipp) Allright I see you say "Only selected UV Map" I click make uncheck then export. Still same problem.

@Kent Davis (mac4kent): thx for checking

Inspecting the exported .dae I can see all textures (in library_images), materials (in library_materials) and corresponding effects (in library_effects) and seemingly applied correctly in bind_material.

So I am not sure if blender is doing something wrong here.
Do you have an example of a collada file with multiple materials/textures that actually displays correctly in MAC finder?

Otherwise leaving up to @Gaia Clary (gaiaclary) to check here...

YesI show you example of a collada file with multiply materials/textures that actually displays correctly in Mac, Yes.
Blender 2.79b is fine no error.

Philipp Oeser (lichtwerk) triaged this task as Normal priority.Mar 19 2019, 1:55 PM

@Gaia Clary (gaiaclary) : could you check on this? Not sure what changed here in 2.8...

@Gaia Clary (gaiaclary) yes thanks.
@Philipp Oeser (lichtwerk) I did inspect deeply and they already fixed. Make sure daily build is today March 19, 2019 not use previous of January 2019 on old Blender 2.80 beta. Please make sure daily build is today (March 19, 2019) https://builder.blender.org/download/
For Macintosh Mojave MacOS 10.14.3
May I have your document .blend please also .dae too.

Gaia Clary (gaiaclary) closed this task as Resolved.Mar 20 2019, 10:48 AM

I have talked with Kent online and he clarified that the issue has already been resolved. So i close this ticket now.