Page MenuHome

EEVEE Diffuse ignores world material
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 Home
Graphics card: nVidia GTX 1050

Blender Version
Broken:
Blender 2.8 Beta date: 2019-01-19 20:58
Hash:b0dee09a6d55
Branch: blender2.7

Downloaded from the daily build page on blender.org.

Short description of error
I've got a buggy file in which EEVEE diffuse shaders always act as if the world is the default material,regardless of what I set it to. If you open the file and render, you'll see that the world material is black, but the darkest shadows are still middle grey.

Exact steps for others to reproduce the error
Not sure, it happened while I was creating some complex toon shaders in EEVEE, with dozens or hundreds of nodes. Could have happened at any point.

Details

Type
Bug

Event Timeline


Here's a simpler file, with just the bug and none of the other stuff.

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

Looks like there is still some indirect light cache, if you free that, you should be fine...
(note cache is not updated automatically if you remove probes)

Will close this, but feel free to comment again if issues persist...