Page MenuHome

Extra ghost edge per ngon in UV editor on Intel HD gfx
Closed, ArchivedPublic

Description

System Information
Arch Linux

  • Linux 4.20.2-1-ck-ivybridge
  • Intel i5-3317U w/ Intel HD4000 / i915 Ivybridge
    • Mesa 18.3.1
    • xf86-video-intel 1:2.99.917+855+g746ab3bb
    • GL_VERSION: 3.0 Mesa 18.3.1
  • nvidia GeForce 740M
    • bumblebee 3.2.1
    • Proprietary nvidia 415.25
    • GL_VERSION: 4.6.0 NVIDIA 415.25

Blender Version
Broken: a712fbda6a17 to a6e6ad07563738b641c9df9e8c48ec0cf9342068 at least

Short description of error
When running on Intel HD / i915, UV editor shows an extra edge per ngon going from any of their edges to (0, 0)

There is nothing at (0, 0), no point can be selected.

Running on nvidia gives correct output:

Exact steps for others to reproduce the error

  1. Open any file with a UV-mapped object
  2. Go into edit mode
  3. Open UV editor

This is probably due to an incorrect GL buffer item count in the draw commands, or a bug with the vertex assembly mode used to draw the points and edges in the driver.

Details

Type
Bug

Event Timeline

After some digging it appears the driver chokes on primitive restart indices; the index buffer for the UV map of the default scene cube is
0 1 2 3 0 255 4 5 6 7 4 255 8 9 10 11 8 255 12 13 14 15 12 255 16 17 18 19 16 255 20 21 22 23 20 255 where 255 is set as restart marker.
The weird thing however is if I get the index buffer content (to get the data above) using glGetBufferSubData, restart markers start working correctly and ghost edges disappear. Will investigate further as this is very likely the sign of a driver bug.

Jacques Lucke (JacquesLucke) closed this task as Archived.
Jacques Lucke (JacquesLucke) claimed this task.

Blender 2.8 requires at least OpenGL 3.3.
Looks like your intel only supports OpenGL 3.0.

https://www.blender.org/download/requirements/

@Jacques Lucke (JacquesLucke) The reported GL_VERSION is wrong actually, it's the output given by glxinfo for a non-core context and Mesa (at least for Intel) acts conservatively when asking for a GL context and reports the lowest version possible matching the requested context settings, which here is 3.0. Asking for a core context yields 4.2 (Core Profile) Mesa 18.3.1 but all the required extensions up to 4.2 are still accessible with lower versions.

Forcing GL 3.[012] using MESA_GL_VERSION_OVERRIDE=3.x Blender refuses to run with a Blender requires a graphics driver with at least OpenGL 3.3 support. message anyway.

Keep that bug closed. It's definitely a problem on Mesa's side related to either buffer invalidation or GL state tracking when drawing with GL_LINE_STRIP.

Hi all,

Could somebody re-check the issue with attached mesa patch and confirm if it helps?

Thanks,
Andrii.