Page MenuHome

Blender crashes when i click on it from task bar and when i open from minimized or go back to the application
Closed, ResolvedPublic

Description

System Information
Operating system: Microsoft Windows 10 (build 17134), 64-bit
Graphics card: Intel(R) UHD Graphics 620
Processor: Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz

Blender Version
Broken:
2.79b release

Short description of error

(ive been using blender for a couple years and i stopped for like 4 months and when i came back to it, this happened, i tried reinstalling and removing files but nothing has worked..)

Blender crashes when i click on it from task bar and when i open from minimized or go back to the application

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Event Timeline

Nicholas (DedosThreat) triaged this task as Normal priority.
Brecht Van Lommel (brecht) raised the priority of this task from Normal to Needs Triage by Developer.Jan 24 2019, 7:33 AM
Brecht Van Lommel (brecht) edited projects, added BF Blender; removed Addons.

I need this really fast if anyone knows a solution..

See the advice here about installing latest drivers:
https://docs.blender.org/manual/en/dev/troubleshooting/gpu.html

Other than that it's unclear what the cause could be.

See the advice here about installing latest drivers:
https://docs.blender.org/manual/en/dev/troubleshooting/gpu.html

Other than that it's unclear what the cause could be.

I tried that :(

Im going to try resetting my pc

This sounds like a graphics driver bug. I used to have similar issues about a decade ago on my old desktop that had integrated graphics (and it wasn't even one by Intel back then). The only solutions I found for that were:

  1. Don't minimise Blender windows ever and/or don't keep Blender open if you're going to be away from the screen for a while (e.g. if the screensaver might pop up, or the machine might go into standby),
  2. Save work before switching away from Blender,
  3. Disable cursor shadows (this helped with some weird cursor flickering issues when moving over the UI, and also improved interactivity)

In your case, I'd suggest to try adjusting each one of the other options in the Advanced System Performance section one by one, taking note of whether disabling certain things makes Blender more stable

In particular I'd probably start by disabling Peek and any fancy visual effects for windows (e.g. animation, shadows, transparency, etc.)

This sounds like a graphics driver bug. I used to have similar issues about a decade ago on my old desktop that had integrated graphics (and it wasn't even one by Intel back then). The only solutions I found for that were:

  1. Don't minimise Blender windows ever and/or don't keep Blender open if you're going to be away from the screen for a while (e.g. if the screensaver might pop up, or the machine might go into standby),
  2. Save work before switching away from Blender,
  3. Disable cursor shadows (this helped with some weird cursor flickering issues when moving over the UI, and also improved interactivity)

In your case, I'd suggest to try adjusting each one of the other options in the Advanced System Performance section one by one, taking note of whether disabling certain things makes Blender more stable

In particular I'd probably start by disabling Peek and any fancy visual effects for windows (e.g. animation, shadows, transparency, etc.)

I just reset my PC and it's working perfectly now :')

Brecht Van Lommel (brecht) claimed this task.

Let's consider it resolved then, not much we can do here to investigate things further.

Nicholas (DedosThreat) triaged this task as Normal priority.Feb 6 2019, 2:59 PM

So after i reset my Computer i found out what the problem was, it was my XP-pen drivers, its been causing this so, if anyone has a fix that would be great :) otherwise i just cant use my pen tablet.

Does it also happen with the latest daily builds (2.79 or 2.80)?
https://builder.blender.org/download/

We recently made some changes to tablet handling which might help here.

Does it also happen with the latest daily builds (2.79 or 2.80)?
https://builder.blender.org/download/

We recently made some changes to tablet handling which might help here.

The Beta?

Both the 2.79 stable daily build and the 2.80 beta have new fixes compared to 2.79b.

Both the 2.79 stable daily build and the 2.80 beta have new fixes compared to 2.79b.

Works perfectly! thanks! ill tell you if it acts up again 😄

Nicholas (DedosThreat) raised the priority of this task from Normal to Confirmed, High.Feb 7 2019, 3:20 PM

Both the 2.79 stable daily build and the 2.80 beta have new fixes compared to 2.79b.

I just was using blender today and its doing the same thing. it didnt fix the pen tablet software ;-;

Brecht Van Lommel (brecht) lowered the priority of this task from Confirmed, High to Needs Information from User.

Did you try 2.79 or 2.80?

Please try tomorrow's 2.79 build, it will include a possible fix for this issue.

Nicholas (DedosThreat) raised the priority of this task from Needs Information from User to Confirmed, High.Feb 11 2019, 7:44 PM
Brecht Van Lommel (brecht) raised the priority of this task from Confirmed, High to Needs Triage by Developer.Feb 11 2019, 7:48 PM

Wow i forgot about this, thanks.

For blender_debug_log.cmd, those are included in the latest daily 2.80 builds. You just run them from the same folder as blender.exe.

i restarted my pc and the beta is working now

but i really wanted the other version to work because im used to the interface
:(

Brecht Van Lommel (brecht) closed this task as Archived.Thu, Apr 4, 5:53 PM
Brecht Van Lommel (brecht) claimed this task.

It's unlikely we will backport the new pen system to 2.79, all focus is on 2.80 now.

Brecht Van Lommel (brecht) changed the task status from Archived to Resolved.Thu, Apr 4, 5:53 PM