Page MenuHome

macOS application is not signed with a developer id
Closed, ArchivedPublic

Description

System Information
Operating system:
Graphics card:

Blender Version
Broken:
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
It would be a better user experience if the application was signed with an Application Developer ID from Apple so that users know it's an official version of Blender and not a potentially hacked/modified version.

Launching unsigned applications requires jumping through extra hoops on newer versions of macOS.

Exact steps for others to reproduce the error

  1. download the latest beta from a macOS computer
  2. try to launch the application by double-clicking on it.

-> get an error message saying you can't launch the app because it is unsigned.

See: https://developer.apple.com/developer-id/

for further documentation on developer identifiers

Details

Type
Bug

Event Timeline

Have you tried stable releases?
I believe they are signed.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Official releases are signed, but daily builds are not.

I agree daily builds could be signed too, I'd like to set that up once, but it's outside the scope of the bug tracker.