Page MenuHome

ctrl+Z closes the whole blender
Closed, ResolvedPublic

Description

System Information
Operating system: win 8 Pro
Graphics card: nVidia GTX 660T

Blender Version
2.8 beta from 14.01.2019

Short description of error

I add object monkey head, apply quick smoke to it. Then hit ctrl+Z a few times trying to undo quick smoke, but instead the whole blender shuts down. Without asking to save file.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Event Timeline

This comment was removed by Bartosz Szentak (Sundaram).

This happens only in edit mode

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.Jan 25 2019, 12:31 PM

I can't reproduce it, please be more precise in you description.
Which object has to be in edit mode?

Also: Please test the newest version of Blender and check if the problem still exists.

matc (matc) added a subscriber: matc (matc).EditedJan 25 2019, 2:18 PM

Broken
2.80, 2019-01-25, bfa8fcc542bf

Steps to reproduce
Open default startup .blend
With "Cube" selected switch into Editmode
Run "Quick Smoke" operator
Hit Ctrl+Z. -> Null pointer exception

Nulll pointer exception
static void mesh_undosys_step_decode(struct bContext *C, UndoStep *us_p, int UNUSED(dir))
us_p->name is "Toggle Editmode"

Additional info
Does not happen when operator (bpy.ops.object.quick_smoke()) is invoked from Python Console window.

I narrowed the problem down to obj.name = "Smoke Domain" (Line 375) in object_quick_effects.py.

# add the smoke domain object
bpy.ops.mesh.primitive_cube_add()
obj = context.active_object
obj.name = "Smoke Domain"

Removing the last line will make the problem disappear.

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 7 2019, 3:17 PM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Mar 8 2019, 11:30 AM

I can not reproduce this.
@matc (matc) can you still reproduce this with the latest beta?

matc (matc) added a comment.EditedMar 8 2019, 3:47 PM

I can't reproduce it. My guess is that 78719abc01f1 fixed this as well.

Sebastian Parborg (zeddb) closed this task as Resolved.Mar 8 2019, 3:49 PM
Sebastian Parborg (zeddb) claimed this task.