Page MenuHome

UI Italian translation applied in Preferences freezes Blender 2.8b on quit or discard changes
Closed, ArchivedPublic

Description

System Information
Operating system: Kubuntu 16.04.3 LTS 64bit
Graphics card:

renderer:	'GeForce GTX 960M/PCIe/SSE2'
vendor:		'NVIDIA Corporation'
version:	'4.5.0 NVIDIA 415.27'

Blender Version
Broken: 2.80 (sub 42), branch: blender2.7, commit date: 2019-01-25 23:33, hash: 1b6da95ccb11, type: Release
build date: 2019-01-26, 00:26:16

Setting Italian translation for Interface, New data and Tooltips makes the os freeze and the only option is brutal power off

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can't reproduce this on my end. Is this still and issue for you with the latest blender beta?

I can't reproduce this on my end. Is this still and issue for you with the latest blender beta?

I downloaded the beta version 8a51af7d1c98, I will see tomorrow if the bug is still there.

Cristian

The problem still persists on branch 141c6073ca39

Can you attach the output (as a file) when you run blender with --debug ?

Can you attach the output (as a file) when you run blender with --debug ?

What kind of output do you need? That in the terminal after running ./blender --debug? Or something else?

Yes, I need the terminal output that you get when you run with the debug flag and make blender freeze.

Because you need to restart the computer, you could do ./blender --debug &> output.txt and get the output saved in a file that you can attach here.

Here is the output

Does this happen if you run the bundled blender-softwaregl instead?

No, it works but unfortunately the software is really slow. When scaling and grabbing, for example, the cube moves jerkily. Infact, it is very slow even without translation applied.
I didn't yet test the latest branch published today.

Sebastian Parborg (zeddb) closed this task as Archived.Feb 4 2019, 8:31 PM
Sebastian Parborg (zeddb) claimed this task.

So this is a driver issue and not a blender issue then.
There is sadly not much we can do in this case as the issue is not on our end.

Maybe this works in newer kubuntu releases as users have reported issues when running older releases. But there is no guarantee that updating will solve this.