Page MenuHome

Collada exporter replacing names that starts with a number with an underscore
Open, NormalPublic

Description

System Information
Operating system: Windows 10 x64
Graphics card: GTX 660

Blender Version
Broken: 2.79b release

Short description of error
When exporting a model as a Collada file, objects and material names that start with some number get it replaced with an underscore. Maybe it also happens on other properties names.

Exact steps for others to reproduce the error
Rename the default cube object's material name to "0Material" and export as Collada (.dae). Now reimport it back on Blender and check the material name ("_Material").

Details

Type
Bug

Event Timeline

(Messed up these comments forms default to Change Status: Resolved!)

XML identifiers can't begin with numbers... although it would generally work, it's technically invalid.

I think you're on to something that if you have 0Material and 1Material and they both become _Material, then this would definitely be a bug. 0Material should become _0Material at the least so that it's sorted correctly.

Sebastian Parborg (zeddb) triaged this task as Normal priority.Jan 29 2019, 2:49 PM

This issue has already been fixed in the master branch (for Blender 2.80). I also believe that this particular issue has been there since ever. Maybe back porting the fix to 2.79 might not be too important?