Page MenuHome

Boolean Difference doesn't work properly
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Gigabyte R9 270x

Blender Version
Broken:
2.80b, 7c438e5366b2, blender2.8b, 2018-12-28

Short description of error


"Difference" in old video looks and works differently in comparison with the app

Exact steps for others to reproduce the error
Create cube and cylinder and try to create "cube minus cylinder". In video works normally but in beta app it just makes an empty hole inside the cube.

Details

Type
Bug

Event Timeline

I see no bug. It works the same, except for the fact that it creates Ngons instead of Triangulation. Hide the cilinder or apply the modifier and you'll see that it works fine. Maybe you got confused because you are in Wireframe without Xray mode and you couldn't see the interior, press Alt+Z to toggle Xray. Also, that's a very old version of blender to compare it to. 2.79's boolean works much in the same way as in 2.8, with Ngons instead of triangulation

I have found out that it works normal if the cylinder is smaller than cube.

But if create a default cube (1x1x1), a default cylinder (diameter == 1), slightly move cylinder up and try to create the same "difference between cube and cylinder" - it causes random bugs. In this concrete case "difference" works like "union"!

Yeah, boolean doesn't work well with edges and faces that have 0 distance and are parallel. It's a known limitation

Jacques Lucke (JacquesLucke) closed this task as Archived.
Jacques Lucke (JacquesLucke) claimed this task.

@Wo!262 (wo262) is right, this is a known limitation.