Page MenuHome

Alembic vertex color export does not work in maya
Closed, ArchivedPublic

Description

System Information
Win 10 Pro, i7-6800k, nvidia gtx 1070

Blender Version
Broken:
2.79b release
2.80, 957b4547aeeb, blender2.8, 2019-01-28

Short description of error
Blenders vertex color channel does not get recognized in maya

Exact steps for others to reproduce the error
Attached are two abc files created in blender and maya respectively with vertex colors applied.
Both of them read fine in blender but only the maya export works in maya.


Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

@Sebastian Parborg (zeddb) 'needs information from user" is when requiring info from user (reporter of the bug)… ;)

When you want a dev to check on a report and cannot confirm it yourself, just assign and leave it as untriaged. :)

Sebastian Parborg (zeddb) triaged this task as Normal priority.Mar 21 2019, 12:35 PM

Hi guys. Just found this bug in Blender. And searching brings me here.
I tried to export vertex color from Blender to Maya. Alembic the only format I found to have "vertex color".
And it's doesn't work. Maya can't see the color.

Is there some progress with a solution?

Note that FBX should also be able to export vertex color data?

Yeah, Bastien. In my case, I found the solution with FBX export.

The structure in Alembic seems to be the same in both files. Both use a subproperty of .arbGeomParams, and both use indexed colours (thanks to D3704). Maybe Maya is very particular about the name of the vertex colour map? That's the only real difference I see; the Blender-produced file has Col whereas the Maya-produced file has colorSet1.

Here is a Blender-produced file that uses the colorSet1 name, together with the blend file I used to make it.


Sybren A. Stüvel (sybren) lowered the priority of this task from Normal to Needs Information from User.Thu, Aug 1, 4:10 PM

I remember that I tried that as well. Anyway, it still does not show up in Maya 2017 and 2018. Funny enough, I tried it in 3ds max 2019 and there they are.

It is just Maya being weird.

vertexColor_blender_colorSet1.abc is also working fine in Houdini 17.5:

If I create fresh geometry in Houdini and add a vertex color the main difference (except for the name which is "Cd" in Houdini terms) is that the vertex colors don't store an alpha channel like Blender does.
Don't know if this is important or causing Maya to not see the vertex colors...

Sybren A. Stüvel (sybren) closed this task as Archived.Fri, Aug 2, 9:38 AM

Thanks for testing. This seems to be a Maya issue, and not a Blender issue, so I'll close this task.