Page MenuHome

sRGB default view transform settings use filmic for color picker
Closed, ResolvedPublic

Description

System Information
Win7x64, gtx580
Blender Version
2.8beta
Short description of error
Colors in material or other scene color fields scale to max of 206 grey.
In both sRGB and Filmic dispaly transforms.

  • Create material,
  • Max any color channel,
  • Screenshot,
  • Test displayed color.

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

That's just how Filmic color management works. In order to support displaying values > 1.0 without clipping, 1.0 needs to be pushed down to make room for such HDR values.

@Brecht Van Lommel (brecht): Should the color swatches not take color management into account? Right now they seem to be hardcoded to use Filmic always, even if you don't *use* Filmic. That seems wrong, surely?

@Brecht Van Lommel (brecht) But:

  1. It doesn't reach 255 in sRGB display transform.
  2. There is no slider to go beyond 1.0 if setting HDR color is the point. Which it probably is not, given 1 is "absolute" reflectance, which is how majority of material color settings are used.
  3. Normal monitor isn't capable of displaying HDR. Pushing the value down is limiting the already very limited resource of color gamut.
  4. Normal monitor is not able do display sensible hdr even if color is being pushed down like this. Meaning - it gives 1, max 2 additional stops with a highly trained eye. One can't tell what color it actually is and at what luminance beyond that.

Imho applying color transforms to swatches is a huge can of worms that requires big consistency investment. For example - you have to differentiate reflective color settings vs light color settings etc., otherwise there is a loss of both - precision and intuitiveness of color control, which is kind of a big deal.
Edit: that might be ok for Filmic, since it is beforehand assumed that what you see is not what you get, but not somewhere else.

Brecht Van Lommel (brecht) renamed this task from Color swatch displayed color reaches only 206 on rgb scale. to sRGB default view transform settings use filmic for color picker.Jan 30 2019, 4:01 PM
Brecht Van Lommel (brecht) reopened this task as Open.

First let's be clear about terminology. There is an sRGB display device and a Default or Filmic view transform. That it uses Filmic even when disabled is a bug.

We would like to add the distinction between albedo and emissive colors at some point, but that's outside the scope of the bug tracker.

Sorry, I should've worded that clearer.
Color type differentiation sounds intriguing :)

Brecht Van Lommel (brecht) triaged this task as Confirmed, Medium priority.Jan 30 2019, 4:22 PM