Page MenuHome

Some transform modes don't apply absolute grid snaping
Open, Confirmed, LowPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX 1080 ti

Blender Version
Broken:
Blender 2.8 January 31, 01:48:40 - 8c8979067490 Beta
Blender 2.79 (It worked)
Blender 2.77 (It worked)

Absolut grid snaping dont work with "Face Inset" and neither with loop cuts.

Exact steps for others to reproduce the error
Turn on the snaping (increment) -> turn on absolut grid snaping -> spawn a plane -> try to snap while loop cutting or inseting faces.

Details

Type
To Do

Related Objects

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

This doesn't seem to be related to absolute grid snap. For me even normal snapping is off when you use loop cup of face inset.

I can toggle it on in loop cut by holding ctrl or doing shift+tab, but this doesn't work with face inset.

Exactly! I also experienced that the face inset isn't even anymore. If I tried to inset for example a rectangle the space on the top and bottom is smaller then the space on right and left side. I switched back to .79 to try it and there it works.
I can work around it but I thought it would help report it.

Campbell Barton (campbellbarton) changed Type from Bug to To Do.
Campbell Barton (campbellbarton) renamed this task from Absolute Grid Snaping to Some transform modes don't apply absolute grid snaping .
Campbell Barton (campbellbarton) lowered the priority of this task from Confirmed, Medium to Confirmed, Low.

Tested 2.79 and loop cut isn't absolute-grid snapping, this is a TODO.