Page MenuHome

Pose In-Betweening doesn't work correctly with animation layers
Closed, ArchivedPublic

Description

Windows 7 64bit

Blender 2.80 #552b2287db86
(2019-02-01 01:46)

When using any of the pose Tween operators (Shift/Ctrl/Alt + E) / (Pose > In-Betweens)
The operator only considers the final absolute keyframe, and not what type of action it is or the layered result.


If you open this file and try to run any of the in-between operators, you will see the bone jump far from where it is, to the center, based on it's curves' exact keyframe values.


(Also, would it be difficult to also add object In-Betweening? Unlike bones, if you animate with objects, your only option ever is/was to manually insert keys in the graph editor)

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

@Joshua Leung (aligorith) unsure if this counts an actual bug or not. So I'll leave it up to you to decide.

Joshua Leung (aligorith) closed this task as Archived.Feb 3 2019, 1:05 PM

Closing as "TODO" - a known limitation that the tools were not intended to support, but could in future when we have the time to do so.

These tools were not intended to take the NLA stack into account. Furthermore, layering/additive behaviour in the NLA has only been properly supported recently, is beyond the scope of the current intended uses of this tool.