Page MenuHome

Wheigt painting tools on imported models odd behavior
Open, Needs Triage by DeveloperPublic

Description


System Information
Operating system: Windows 10 x64
Graphics card: AMD Radeon RX 580

Blender Version
Broken: 2.80, 2019-02-02 00:58, 4ef09cf937f2
Worked: None I tested

Short description of error
When using the wheigt painting tools on imported models the behavior is wrong/broken, if you set the skeleton into pose mode you are unable to select the mesh, to set it into wheight paint mode, preventing you from wheight painting the model or tweaking wheigts. I tried several other FBX and Collada files and all have the same problem.

Exact steps for others to reproduce the error
Open the provided FBX and import it.
Set the armature to pose mode and try selecting the mesh in the viewport.

Details

Type
Bug

Event Timeline

Think this has been reported before, but cannot find the relating report atm...

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.Feb 4 2019, 5:33 PM

It seems to work for me when I select both objects in object mode (with the mesh being the active object). When I then switch to weight paint mode, the armature is set to pose mode.
@Haruko Kojima (Anurae), can you confirm that?

Yes i can confirm that it works like this, however when you set up a mesh + skeleton inside Blender natively for example it also works fine like i described it,
another problem is you have to leave wheigt paint mode to select a different mesh object within the scene, in this case the head for example, which again works
fine if you create the items natively in Blender.

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Feb 4 2019, 11:04 PM