Page MenuHome

(2.8) Slider properties sometimes cannot be changed after being keyed.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7 64 bit Home Edition
Graphics card: nVidia GeForce GTX 970, driver version 417.71

Blender Version
Broken: v2.80.43, Date: 2019-02-02, Hash: 4ef09cf937f2, Branch: Blender2.7
Worked: 2.79b release

Short description of error
Slider properties in Blender sometimes cannot be changed once they have been keyed, meaning you cannot easily animate these properties. This can be bypassed by entering the graph editor and manually editing the curve.

Exact steps for others to reproduce the error
This should be easily reproducible in the factory default scene through the following steps:
a.) Add a particle system to the cube.
b.) Switch particle type to Hair.
c.) Insert a keyframe on the "Start" value in the Timing sub-tab of the Render tab.
d.) Change frames in the timeline.
e.) Attempt to change the "Start" value. The value should not change either via scrubbing or typing in a value, though you can still key the value.

This is just one example of the bug. It should be noted that I've encountered the same bug with shape keys but I cannot reproduce the error reliably.

Details

Type
Bug

Event Timeline

Dan (D) created this task.Sun, Feb 3, 4:50 AM
rndmnm added a subscriber: rndmnm.Sun, Feb 3, 12:27 PM

Would T61111 be caused by the same issue?

William Reynish (billreynish) triaged this task as Confirmed, Medium priority.Sun, Feb 3, 4:13 PM

I assume this is a depsgraph issue?

Same goes for the viewport display object color. It also gets blocked when it has a keyframe. It seems as if there's a dozen or so properties which have this issue.

T60559 is the report for material viewport display color [@William Reynish (billreynish): dont have this for the object viewport display color]

Sergey Sharybin (sergey) closed this task as Resolved.Mon, Feb 4, 2:15 PM

The issue is actually solved by that commit.

Thanks for the report!