Page MenuHome

Automatic Weight paint problem
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX 1070
Intel i7 8750h

Blender Version
({F6492126}2.8 Beta) 2/1/2019

Short description of error
Initiating automatic weight paint in any way regardless of how the mesh is selected, The bones are assigned very badly and misguided to the obvious targets of the mesh

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Not exactly sure what you mean by

  • "assigned very badly"
  • "misguided to the obvious targets of the mesh"

Maybe you could be more specific to what object we are talking about? (the selected Shirt?)
Maybe you could share screenshots or another blend with different poses and explain exactly where things go "wrong" for you?

For example, the "body" mesh.

I simply select the mesh-->select the entire armature-->assign to automatic weight paint--> and find that vertices such as the lips and fingers are very inaccurate when assigned via automatic weight paint

Did this work properly for you in 2.7? Please provide an example blend file of the problem. Do consider that weight paint won't follow the mesh correctly if you have disconected vertices in your geometry.

actually, I wasn't able to open it in 2.7, but here are some screen shots of the issue{F6518510}

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

That tool is not a magic wand to rig your mesh all by itself, at best it can be used as a good initial point. Improvements are always possible, but there is definitively no bug here, closing.