Page MenuHome

Bevel Bug
Open, Confirmed, LowPublic

Description

blender-2.80-07765499abee-win64

on the cylinder with a lot of segments, bevel doesn't merge in one point. Create nice see n-gon(normal we must see the only verts in one point)

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Normal.
Howard Trickey (howardt) closed this task as Invalid.Feb 5 2019, 8:56 PM

This is just the way bevel works right now, so you are asking for a new feature.
I could solve this by running a 'remove doubles' automatically after doing bevel, and some have asked for that in the past. But I worry about doing that everywhere on the model as it may merge things that the user didn't intend to get merged.
For now, the workaround for you as a user is to do a 'removed doubles' manually after a bevel like this.

Longer term, I want a much better handling of what happens with geometry collides like this during bevel. For now, I'm closing this bug, to keep bug tracker clean, and will add it to my Bevel TODO list.

Sergey (Drakosha405) added a comment.EditedFeb 5 2019, 9:05 PM

thx for u hard work// but here new gif 1st part 48 segments 2nd 200 segments

on 48: all 48 vertexes be in one position (can remove doubles)

on 200: they don't have the same position. ( remove doubles don't work)

OK, now I see the problem you are talking about and agree that it isn't what I thought (that you just wanted automatic merging of the verts). I suspect that the problem with the cylinder is that the method I use to calculate the vertex positions is numerically sensitive and misbehaving due to using floats instead of double precision. I will see if that is so, and if so, whether or not I can rearrange the calculation somehow to fix.

On cube:
The middle loop has deformed when we bevel sharp corner. on the large mesh, we cant see this deform. but if mesh small all bevels be close to each other & mid loop have nice see deform.

Small mesh

Howard Trickey (howardt) triaged this task as Confirmed, Low priority.Feb 15 2019, 2:48 PM

I found and fixed the problem with the cylinder, with commit rBdd97b09fa8d5 ,

The cube problem is harder to fix, but I might be able to fix it. It is not a high priority, however.