Page MenuHome

OBJ IMPORT BROKEN
Closed, ArchivedPublic

Description

System Information
MAIN MONITOR:
2560 X 1080
GAOMON MONITOR:
1920 X 1080

AMD RYZEN THREADRIPPER 2950X 16 CORE 3.50 GHZ CPU
Ram 32 Gigs
Windows 10 Pro
Nvidia Geforce RTX 1080

Blender Version
blender-2.80.0-git.38984b10ff7b-windows64
Broken:
First Off NOT changing the Vertex Order needs to be the default. But on top off that if you bring in any OBJ with multiple materials on different Polygon faces it messes up the material's placement. I brought in a figure that had separate material for Arms, Legs, Torso etc. Also it seems to flip the figure's polys inside out. Lastly even though the materials are there Adding textures to them fails.
Worked: (optional)

Short description of error

Exact steps for others to reproduce the error
Import an OBJ with multiple materials on different faces and select keep Vertex Order.

Details

Type
Bug

Event Timeline

Could you provide a sample file which exhibits this behavior?

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Indeed…


I have attached a zip with an OBJ and its textures. Just import it and select options : Don't change Vertex Order and Keep Polygroups.
Select Rendered Display render preview.
On FBX import it brings things in properly if the maps are in the same folder. This is not the case for obj import.

I included an image of the FBX import so you can see what it should look like.

Here's what the console shows me on Mac on build 766741b0aa8c

(  0.0001 sec |   0.0001 sec) Importing OBJ '/Users/admin/Downloads/OBJ_EXAMPLE/BODY_OBJ_EXAMPLE.obj'...
  (  0.0017 sec |   0.0006 sec) Parsing OBJ file...
    (  2.2181 sec |   2.2155 sec) Done, loading materials and images...
WARNING, currently unsupported 'tf' filter color option, skipped.
WARNING, currently unsupported 'tf' filter color option, skipped.
WARNING, currently unsupported 'tf' filter color option, skipped.
WARNING, currently unsupported 'tf' filter color option, skipped.
WARNING, currently unsupported 'tf' filter color option, skipped.
WARNING, currently unsupported 'tf' filter color option, skipped.
WARNING, currently unsupported 'tf' filter color option, skipped.
    (  2.2389 sec |   2.2363 sec) Done, building geometries (verts:84104 faces:84102 materials: 7 smoothgroups:1) ...
    (  3.5119 sec |   3.5093 sec) Done.
  (  3.5131 sec |   3.5120 sec) Finished importing: '/Users/admin/Downloads/OBJ_EXAMPLE/BODY_OBJ_EXAMPLE.obj'
Progress: 100.00%

The issue is with the materials, not the mesh. The mesh imports fine, the normals are oriented correctly, and the default Principled BSDF shaders work fine. If the .mtl loads the above error occurs and you have to enable back-face culling and set the material to opaque instead of alpha blend to make it look reasonable, and even then the normal maps do not seem to be applied correctly.

As best I can tell this due to a limitation of the .mtl loader rather than a bug per say.

Ok so the mesh is fine but the Materials seem to be not reading in properly. That is good to know. I can tell you that the mesh has been tested in multiple applications and the .mtl file is being read in correctly. No scrambled normal maps , no transparent materials etc.. So at least now I know the issue is with the .mtl reader.

Bastien Montagne (mont29) closed this task as Archived.Feb 7 2019, 11:35 PM
Bastien Montagne (mont29) claimed this task.

The main issue here is the 'blend mode' of the materials set to Alpha Blend, because of their MTL illum set to 4 (which, according to http://paulbourke.net/dataformats/mtl/, enables glass transparency and raytraced reflection). No idea why this is using that model, tbh.

And the 'tf' messages are, as stated by their very selves, just warnings. They do not 'break' anything (transmission filter is a very rarely used feature of MTL afaik).

thanks for the report, but I would not really consider this a bug, MTL (and other 'fixed' shading pipelines) are not always easy to convert to new procedural shaders, we do our best here to support basic cases, but…