Page MenuHome

array modifier not rendered properly with colour ramp ( cycels
Closed, ResolvedPublic

Description

Win 10
intel i5
amd radeon

I created 1 pushbutton ( cube ) assigned an array modifier to duplicate it 16 times , did not apply the array modifier
Assigned colour ramp ( red , orange , yellow , white and set to constant ) ) , separated the y vector , so the colours go from red -->white ,

Cycles preview render shows the correct output , the final render does not , only white buttons


Here's the file

Details

Type
Bug

Event Timeline

Edit :after rendering , cycles preview now shows only one coloured button ( array modifier not applied )
But this only happens when the Ýçoordinate is seprated
Have a look into the shader editor and switch separation coordinates and look at the cycles preview render

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

This is very confusing. Looks like the wrong bounding box is send to cycles.
Sometimes, going to edit mode and back solves the issue. But not every time.
Also I was not able to reproduce this in a new file yet.

Brecht Van Lommel (brecht) closed this task as Resolved.Apr 1 2019, 2:14 PM

This is fixed now, and the result matches the final render, same as in 2.79.

Generated texture coordinates map to 0..1 within the mesh without modifiers. Other behavior is useful too, but that's not how it was designed to work and there is some advantage to having a fixed texture coordinate mapping regardless of the modifiers, especially if the modifiers are animated.