Page MenuHome

Shift +F1 append not working
Closed, ArchivedPublic

Description

i9 14 core
NVidea Titan Pascal

dd3f5186260e

The short cut shift+F1 for append only allows you to get to the top of the .blend file stack. You can not get below that to find the particular article/object etc that you are looking for.

File append works as normal.

Checked and reported by 4 people of same facebook group.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.Feb 9 2019, 1:39 AM
Brecht Van Lommel (brecht) claimed this task.

Shift + F1 is not the shortcut for append, it is for opening a file browser. All the Shift + F? shortcuts are for opening editors.

Just to clarify, is this an intended change from 2.7? In 2.7 Shift+F1 was the shortcut for Append.

Yes, it was an intentional change. The F2 menu is the replacement in 2.8, for consistency all Shift + F? shortcut switch editors now.