Page MenuHome

Dyntopo frequently deactivating during sculpting
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GeForce RTX 2080 Ti

Blender Version
Broken: 2.80, 036ec5cae4f7, blender2.8, 2019-02-11

Short description of error
In Blender 2.8, when sculpting in Dyntopo mode, using Shift and multiple strokes to smooth, sometimes undoing a couple of times, and brushing again, I frequently encounter Dyntopo mode spontaneously switching off.

It always happens following a short freeze, showing the wait pointer.

I’m using a Wacom Intuos Pro Medium tablet, and I’m running the latest Windows 10 version.

I was guessing it might have something to do with the recently added Topology Rake, which I use in every brush, including the Smooth brush.

Thanks.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Feb 12 2019, 12:47 PM

I can't reproduce this on my end. Could you see if it still happens with the latest blender beta?

If it does can you then perhaps setup a test scenario where you can easily trigger this behaviour?

Hi Sebastian,

I'm using today's Blender build, but I already encountered the issue in previous versions.

It's hard to pinpoint what exactly triggers it. I'm sculpting using a lot of brushes, smoothing, undoing and redoing. I suspect it occurs:

• when using the Snakehook brush in Dyntopo mode, with Topology Rake turned to 1.0.

and/or

• when alternating brushing and smoothing with very fast successive strokes, with Dyntopo and Topology Rake activated, also in the Smooth brush settings.

One more detail is that I've got Stroke ➔ Input Samples set to 4.

I've sculpted some more, and it just happened again, while the Blob brush was active, and I performed a lot of fast strokes while holding Shift to smooth.

Both the Blob brush as well as the Smooth brush were set to full Topology Rake, Stroke Input Samples were set to 4, and the mesh was reasonably high-poly: 378,248 tris.

I also frequently use Control + drag to zoom in and out, between holding Shift and dragging for the smooth brush strokes.

Another detail: I'm using Dyntopo's Constant Detail mode.

Can you attach a simple .blend file that I can use to reproduce this?
That way we can be sure that I'm using the same settings as you do.

Hi Sebastian,

I'm sorry, it's a confidential project for a client. Is there a way to submit the scene privately?

Thanks.

Can't you reproduce this on the default cube?

I've just tried on a subdivided cube, but can't reproduce it. It's probably a specific problem. It might also have to do with the length of a session. In other words: more risk of the issue occurring as you've been sculpting for a longer time.

Well, if I discover more details when it occurs, I'll surely let you know. And if you can provide a way to send the scene privately, I'll be happy to do so.

One more detail: my main 3D view window is split into three parts: at the bottom there are two Image Editor views with reference images. I don't know if that is of any importance, but I thought to mention it.

One more observation: Dyntopo being switched off occurs only when I smooth with individual strokes. So I hold down Shift, then I stroke, lift the pen, go back to the start position, stroke again, and so on, in a very fast pace, and holding Shift all the time.

There will probably be multiple developers looking into this. So public files are preferred,
There is no rush. So see if you can reproduce this with a file from scratch and let me know how it goes.

Thanks, I'll do so more tests as soon as the furious deadline monster is not breathing fire into my neck anymore. 🙂

Bastien Montagne (mont29) closed this task as Archived.Mar 18 2019, 9:24 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.