Page MenuHome

Blender 2.8: Shader node - Linking to Materiel Output/Volume causes a crash of Blender
Closed, ArchivedPublic

Description

System Information
Operating system: Win10
Graphics card: AMD Vega64

Blender Version
Broken: d3870471edd7

Short description of error
Shader node - Linking to Materiel Output/Volume causes a crash of Blender

Exact steps for others to reproduce the error
Create a 3D bezier curve (object data: fill mode=full, depth=0.1). Switch 3D view to shade (LookDev) view. Create a material (add shader) for curve (Eevee). Add Volume Absorb or Emission. Link to Output - Volume. Crash!

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can not reproduce this.
Does it still happen for you with the latest build? https://builder.blender.org/download/
Always provide the build hash and double check your date.

I can not reproduce this.
Does it still happen for you with the latest build? https://builder.blender.org/download/
Always provide the build hash and double check your date.

Could you try it for 3D curve? I add version of Blender to description. Thanks.

Still can't reproduce. Does the following file crash for you?

Still can't reproduce. Does the following file crash for you?

Thanks for the file. I tried to open the file and when I changed the radius of 3d curve (+enabled volume in eevee part) and deleted a link and made a new link and changed again radius - Blender crashed.

I tried those steps on my laptop and there is no crashes.

It seems to be a problem with my AMD Vega64 and Eevee/node shader. I tried to make debug and there is bad instance of Mesh structure in 3D Curve ( bad reference to vertices ).

There is a similary problem in other node shaders when I make many changes in value of some node (for ex. changing a value with mouse moving). Blender is very unstable in this way.

You can check if this is a driver issue by downloading this dll and copying it so its located in the same directory as 'blender.exe' and run Blender normally.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.