Page MenuHome

Particle edit does not render children (Cycles) even though Display/Children is being checked
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 64 bits
Graphics card: nvidia gtx

Blender Version
Broken: 2.80 036ec5cae4f7 2019.02.11

Particle edit does not render children (Cycles) even though Display/Children is being checked.
This used to work in 2.79. See attached screen and blend file (HairCard2 object has particle edits).

On a side note, I noticed that in particle edit mode, C circle select mode, middle mouse button was used to deselect (left mouse to select). This seems counter-intuitive, knowing Alt seems to be the modifier to deselect in 2.8 (i.e. Alt+A to deselect all). I think deselection behavior should be unified throughout the app.


Event Timeline

Olivier Lau (yoli) renamed this task from Particle edit do not render children (Cycles) even though Display/Children is being checked to Particle edit does not render children (Cycles) even though Display/Children is being checked.
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can't seem to get the child hairs to display in 2.79, latest build from here: https://builder.blender.org/download/

Am I missing something or is this the case with the latest 2.79 build for you as well?

I was following a video tutorial using 2.79 and child hair is displaying in the video, this is why I said this used to work in previous version. I can send you a screen (need email) but not publicly as the video is not public. I didn't try myself in 2.79 though, I was assuming it was working since I saw that in the video.

Can you try to reproduce this in both 2.79b and the latest 2.79 build then and get back to me?

Ok so I made a few more testing, let me clarify because the initial statement was not totally right. I managed to have children visible in 2.79b in particle edit mode but we need to opt out of Clycles in viewport (SHIFT+Z). However, in 2.8, SHIFT+Z is just changing the shading type and I didn't find a way to see children being displayed in particle edit more regardless of the shading type chosen. Please check this with the file I attached, if you find a way to display children in particle edit mode please let me know how.

Can you simply give me a 2.79 file where you can see the children in particle edit mode?

Here it is :

I tried a new project from scratch in 2.8 and can see children in particle edit mode, but still not with the 2.8 file I attached originally. So there must be something I did that broke it, I'll try to repeat the steps and see. I'll update if I can find anything.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.

The reason seems to be that the children become invisible with Path steps set to 8 or more.

If you set them to less than 8, they do display but they do not seem to be subdivided as they should with the steps parameter:

2.79:


2.8:

blend file:

@Clément Foucault (fclem) feel free to reassign if this is not for you. I'm guessing this is render related (?)

Thanks @Sebastian Parborg (zeddb), I confirm that moving Path Step to a value lower than 8 in particle edit properties/Display section enables to see children whereas a value of 8 or above hides them.