Page MenuHome

right mouse click on join window area crashes blender
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7 64bit
Graphics card: GeForce 1060

Blender Version
Broken:
blender-2.80.0-git.036ec5cae4f7-windows64 (12. Feb. 2019)
blender-2.80.0-git.55e3c17ccc1-windows64 (14. Oct. 2018)
early Feb. 2019 build on Ubuntu 18
Worked: (optional)
2.79 release

Short description of error
the window area borders offer a context menu to join/ split areas.
right-clicking on the "join area" has a high chance of crashing
blender, if (any other) two areas were joined previously.

Exact steps for others to reproduce the error

  1. start blender
  2. right-click on the border between outliner and properties area
  3. join those areas, e.g. towards properties
  4. right-click on the border between 3d view and timeline
  5. RIGHT-click on the "join area" menu entry
  6. do nothing with it, move the mouse away to make the 2 context menus disappear
  7. repeat steps 4 to 6 until blender is gone

found this as i tried to split and join areas by hotkeys (f4 to split and Q quick menu to join).
happens on a self-compiled build on ubuntu from about a week ago as well.
my impression is that each right click on "join area" has about a 30 to 50 percent
chance to crash to desktop.
however, it does not crash (or takes a lot of repetitions?) if no other areas were
joined before.

cheers,
boogie

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Resolved.
Philipp Oeser (lichtwerk) claimed this task.

This should also be fixed by rB57f0b175d7c9
(was crashing in ED_screen_user_menus_find because of no SpaceLink in between editors...)

Will mark this as resolved (but make sure to comment again / reopen if issues persist in tomorrows build...)

it is fixed indeed!
oh boy... what are the odds? i reportet a bug that was in there for months and months and i reported it just as the fix was already committed, but before the nightly build was out...