Page MenuHome

Installation error for Blender Source Tool
Closed, InvalidPublic

Description

System Information
Intel(R) Core(TM i7-7700HQ cpu @ 2.80gHZ
NIVIDIA GeForce GTX 1050 Ti 4 GB
16.0 GB RAM

Blender Version
Broken:
blender-2.80-ba6cf3cdb649-win64

Short description of error
I reported this to the maker of this installation file first and it was good on his end.
Installation: Blender Source Tool
Installation for Add-ons varies.
Each number in list are different scenario:

  1. Installation is an success but check box nor description is visible in the Add-ons list when searched for.

2)Installation is an success but requires a "upgrade 2.8x required" and display and error message when clicked on.
(link for picture below)
https://cdn.discordapp.com/attachments/545304646831308810/545381321913008169/Capture.PNG

3)Installation fail and displayed error message.
(link for picture below)
https://cdn.discordapp.com/attachments/538073972072251392/545038678897066011/Capture.PNG

Exact steps for others to reproduce the error
(this is the file for Add-ons)
https://github.com/Artfunkel/BlenderSourceTools
(its use is to export/import .DMX & .SMD files)

As Blender 2.8 opens.
go to Preference
Select Add-on tab --> install... --> select "BlenderSourceTools-master.zip" --> click install
(i would have the .zip file outside the main blender folder but have it together in a separate folder called I made called "Blender")

Details

Type
Bug

Event Timeline

The bug tracker isn't a support system. A better place to troubleshoot this will probably still be with the addon author - try contacting him again. For instance, your second picture clearly indicates an old set of files attempting to be installed -- beyond the "upgrade to 2.8x required" message, the error message itself references "scene_update_post" which is no longer in 2.8 and is no longer in the addon developers git repository at that location either. Double-check where you got your zip from.

Secondly, for his git repository organization, you cannot use the "Download Zip" option on github. The structure of the files will not be in the proper layout that blender expects. You will need to ask the addon developer for a proper zip.

Sebastian Parborg (zeddb) claimed this task.