Page MenuHome

Ctrl + z at random closes Blender
Closed, ArchivedPublic

Description

System Information
Operating system: x64 bit Windows 10
Graphics card: Nvidia GTX Gefroce 1050Ti Notebook

Blender Version
Broken: Exit
Version: Blender 2.8 Beta Release

Short description of error
ctrl+z does undo as normally. When working fora long period of time, ctrl+z randomly would close the application and losing the unsaved data it was running. I was working with some models. Happened to me 3 times in one day.

Details

Type
Bug

Event Timeline

Application closes randomly when pressing ctrl + z aaaaand would like this to be fixed quickly. Lost my unsaved work 3 times. Gets annoying having to save every minute

Look at the auto-save and recovering features.
https://docs.blender.org/manual/en/latest/troubleshooting/recover.html

And, need more details what causes the crash, developers need to be able to reproduce it to fix it.

Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.

We need steps to redo the crash.

Could you give information about what you were doing at the time?
(which mode, what tools you used etc).

from my knowledge, pressing ctrl+z several times to undo any action done to a model crashes the program. If you for example make a cube or any shape do a bunch of things to the cube, doesnt matter what those actions are, extend the cube, scale it, what ever, then press ctrl + z about 3-5 times to undo what you did. one of those key combos will crash the program completely.

I wanted to add more detail to my previous comment. I was in edit mode . after pressing ctrl+z several times, it will go from edit mode to object mode. If you press ctrl+z after it switches to object mode, it will crash the application.

I can't redo this based on rough explanation, the report us still missing steps.

  • Write down exact steps that crash.
  • Check if they crash every time, or just occasionally.
  • If it's not crashing every time, can you find operations that crash say at least half of the time.
Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Following bug tracker policy, closing report after 7 days due to insufficient information to investigate further. We can reopen the report if more information is provided.