Page MenuHome

Quit dialog still shows up even with Prompt Quit turned Off
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: NVIDIA Quadro 6000

Blender Version
Broken: 3b3eba637406

Short description of error
Using a shortcut to quit Blender (Ctrl+Q) still prompts the Quit dialog even though Prompt Quit is off.

Exact steps for others to reproduce the error

  • Disable Prompt Quit from Preferences > Save & Load
  • Ctrl+Q to Quit

Thanks!

Event Timeline

I don't think this is a bug. We are talking about two different dialogs here.

Imo Ctrl+Q should always show this dialog.

From the user point of view it's the same concept: a dialog that prompts on quit. @William Reynish (billreynish) what is your take on this?

As I see it we could just remove this option. It’s an artifact from a time when Blender didn’t have a proper dialog box for unsaved changes - which we still don’t have for File > New. (highly important that we add this btw!)

Because the quit prompt can detect if the document is saved, there isn’t any prompt appearing unless there are unsaved changes. Using Blender without is a lot more clumsy - it doesn’t ask you to save if there are unsaved changes, and the clumsy little dialog appears even if changes are saved.

At some point in Blender development we have been cautious about adding or improving things, leading to lots of ‘we’ll make it an option’ situations. We can often simplify things a lot more of we just make a clear decision. No other software for artists has an option to remove the dialog to save unsaved changes.

Campbell Barton (campbellbarton) closed this task as Invalid.

Closing since this isn't a bug (while it could work differently, it's working as intended). If someone on the UI team wants to open a design task they can.


Edit, this was opened by @Pablo Vazquez (pablovazquez) - setting as design task.

Campbell Barton (campbellbarton) reopened this task as Open.