Page MenuHome

Billboard particles not displaying in Eevee viewport, render
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 x64
Graphics card: R9 280X

Blender Version
2.80 build 790cb7799dcf

Billboard particles do not show up in eevee. Setting the rendering mode to object, halo, point, or other settings works fine, but billboards do not display in viewport or rendered. See attached file:

Revisions and Commits

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 50.

This option and associated code could be removed. It was only supported by Blender internal which is no longer available.

Billboard particle support in Eevee (and maybe Cycles) could be useful, but would not consider missing support for that a bug in itself. Mainly having an option that does nothing.

That’s a pity. I knew cycles didn’t support them but assumed that eevee did since the option was still present. If it’s not supported at all the option should under be removed from the UI.

The biggest feature I was hoping to use from billboard particles was the ability to animate them using a sprite sheet. Arguably that’s actually a distinct feature from a particle that always faces the camera, though they go well together. Something to consider for the future, but today it’s just a UI bug.

So what should I do concerning this? Remove the option from the code completely? Thus breaking old file? Edit do_version to change existing particle system type to None?

Yes, remove the option from the code and do a version patch to set the type to None.

As long as we don't support this old files will break, any files with Blender Internal materials are broken anyway.