Page MenuHome

Edge selection wrong with Intel HD 3000 on macOS
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: macOS High Sierra (Version 10.13.6) platform: Darwin
Graphics card: Intel HD Graphics 3000
system-info.txt file attached.

Blender Version
Broken:
version: 2.80 (sub 44), branch: blender2.7, commit date: 2019-02-15 14:15, hash: faa255c0a4e4, type: Release
build date: 2019-02-15, 16:23:20 as found on the splash screen - attached.

Worked: (optional)
Vertex Select, Face Select Worked as expected

Short description of error

In object "edit mode", (Edge Select) doesn't work properly. If edge select mode is on, the target edge doesn't select instead random edge gets selected. A 1 min video (I made) of the bug in action can be found here: https://youtu.be/qVmsE76ZF4I

Exact steps for others to reproduce the error
Go to Edit mode and try selecting 'edge select' mode, the targeted edge doesn't select, instead random edge gets selected. A .blend file is attached.

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.

I can't reproduce the issue. Are your drivers up to date?

Can you test if this still happens in the newest Blender build?

I can't reproduce the issue. Are your drivers up to date?
Can you test if this still happens in the newest Blender build?

Hi Jacques Lucke,

  1. Are your drivers up to date? - Yes, I am pretty sure the drivers are up to date. I am running mac version 10.13.6 with all latest updates from Apple.


  1. newest Blender build? - Yes, just downloaded and tested on my system and the issue still persists with the newest build.

splash screen attached.

Thanks.

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Feb 20 2019, 6:47 PM

I assume this is still an issue?

I have been a little out of the loop in regards to hadware related bugs, @Sebastian Parborg (zeddb) , @Clément Foucault (fclem) : does this ring a bell for you?

@Philipp Oeser (lichtwerk) there are many reported issues like this. All of them seem to be because of buggy/outdated drivers.
I don't think we have a ticket for selection issues like these (at least yet).

FYI attached animated GIF of behaviour

FYI edge selection works fine in transparent mode, in both wireframe and 'surfaced' mode. In non-transparent mode neither mode selects correctly, as per previous GIF.

Brecht Van Lommel (brecht) renamed this task from Edge Select in object edit mode does not select the targeted edge to Edge selection wrong with Intel HD 3000 on macOS.
Brecht Van Lommel (brecht) triaged this task as Waiting for Developer to Reproduce priority.May 29 2019, 2:42 AM

I can't reproduce this with Intel Iris Graphics 6100 on macOS.

The 3 reports about this are all using an Intel HD 3000, so it's probably specific to that. Rather difficult to investigate since I'm not aware of any developer with this hardware available for testing.