Page MenuHome

Editor window layout change causes modal operator's context.area returning None, in turn, causes event timer fail to trigger tag_redraw() after 1 second of inconsistent activation.
Closed, ArchivedPublic

Description

System Information
Win 10 Pro,
AMD 1700x w 32GB & 1080

Blender Version
Broken:
2.8 positive symptom with Shortcut VUR addon and with my own script.

Worked: (optional)
2.79 with screencast key addon

Short description of error
Note: I don't think this is a problem on the Addon part since screencastkeys on 2.79 used the exact same method to achieve timely redraw for the on-screen messages.

Without window layout change, both addons worked correctly, the on-screen input message disappears after a short time.

After window layout change, context.area within MODAL method returns None, and on-screen input messages would not refresh until triggered by another input.

Returning to previous window layout won't fix the issue.

The event 'TIMER' is still triggered consistently, the screen though, would not redraw when the 'TIMER' event hits.

Exact steps for others to reproduce the error
1, Enable said addons in their corresponding version of Blender,
2, Start the modal operator with the button in the Side panel
3, Observe as the input messages disappear
4, Maximize the window, or change to a different layout
5, Notice the messages do not disappear unless new input such as MouseWheelScroll happens, and it would timely redraw for a second or two, and stop again.

Nvm this report, I found another report that is basically the same issue here:
https://developer.blender.org/T36711

Modal context is lost upon window change because it was designed to do that.

Details

Type
Bug

Event Timeline

Brent Lio (remotecrab131) closed this task as Archived.Feb 21 2019, 5:12 PM
Brent Lio (remotecrab131) lowered the priority of this task from Needs Triage by Developer to Confirmed, Low.
Brent Lio (remotecrab131) updated the task description. (Show Details)