Page MenuHome

Multiple Hair Systems Not visible while in particle edit mode.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: 2x GTX 1080TI's (Not in SLI)

Blender Version
Broken: 2.80 February, 19th 2019
Worked: 2.79b Stable Release

Short description of error
All hair particle systems (except active selection) disappear or are hidden when multiple hair particle systems are created on one mesh and the user enters particle edit mode.

Exact steps for others to reproduce the error

  1. Using a standard UV sphere add a particle system, and switch it to hair.
  1. Add another particle system to the same mesh, change seed to see both hair systems.
  1. Enter edit mode for either particle system and the other will disappear until re entering object mode. However it will disappear again upon entering particle edit mode.

In 2.79b Users could see all active hair systems while in edit mode (Unless hidden in the particle tab) to allow for hair style grooming to see if different hair systems were colliding or passing through each other. This helped create a cohesive hair style without having to switch in and out of object mode and guessing where the other systems were.

Thanks for everything!

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

I add test files here:

2.79:

2.8:

in particle edit mode:

2.79: Both particle systems are visibled
2.8: Only the selected particle system is visibled

I add a .diff between the 2 particle edit.c too if it can be useful:

https://www.diffchecker.com/wUQsL7WY

(I like diffchecker website btw, if someone is interested)

left: 2.8
right: 2.7

Clément Foucault (fclem) raised the priority of this task from Confirmed, Medium to Confirmed, High.Jul 9 2019, 8:14 PM