Page MenuHome

Problem with Orientation
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia GTX 1060

Blender Version
Broken: Blender 2.80 Beta
Hash: ec471a9b1c14
Date: 2019-02-15 23:44

Short description of error
Changing orientation ONLY WORKS when you change It, In a sector below main taskbar (top bar)

The button in viewport representing Orientation will not affect the Gizmo orientation.

The shortcut for Orientation window will not affect the Gizmo orientation.

Details

Type
Bug

Event Timeline

Topbar is by design : area where to set gizmo properties.
A gizmo can be used for common transformations (move, rotate, scale) but also for operators in edit mode (extrude, spin, shear).
Actual design allows to set an orientation specific to gizmo and another global one for any other operator called by pressing a shortcut Key G,R,S.

So, you can use gizmo to move according to View axis and doing everything else by using respective shortcuts according to Global axis.
If these menus were doing the same thing : there would be no reason to keep this repetition and one should be eliminated.

But the menu in 3D Viewport header can affect Gizmo orientation if you let orientation menu in Topbar to Default.

The orientation in Topbar is not for every tool, it is the orientation of chosen active tool.
For example, you can set Move tool orientation to View in Topbar.
Then, click Rotate button in toolbar and set its orientation to Local.
Click to use Scale tool and set its orientation to Cursor.
Now, if you switch between the tools by clicking in toolbar, you can see that previously precised orientations are kept.

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

As stated, this is currently by design and not a bug.