Page MenuHome

.blend file not visible in Finder on Mac
Closed, ArchivedPublic

Description

System Information
Operating system: Mac OS/X
Graphics card:

Blender Version
2.79b release

Short description of error
.blend file sometimes not visible in Finder on Mac.

Exact steps for others to reproduce the error
I'm using Blender 2.79b on an iMac [OS/X 10.11.6].

Sometimes when I save my file [myFile.blend], I subsequently can't find it in the Finder view of the folder where I know it resides. Steps:

In Finder, locate my .blend file. Double click it to open in Blender
in Blender modify something
File -> Save. Save to the same name - overwrite.
close Blender.
Back in the Finder view I see a file with the name 'myFile.blend1' but the file 'myFile.blend' is not visible.

In Terminal:

cd - to directory where these files reside
ls - shows the 'myFile.blend' is there along side 'myFile.blend1'.
If I do this in Terminal:

touch myFile.blend
the file 'myFile.blend' becomes visible again in the Finder view.

Details

Type
Bug

Event Timeline

This sounds more like an issue with Finder than blender as you can still find the file via the terminal.

@William Reynish (billreynish) I don't think we do anything funky with files on mac, right?

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Feb 28 2019, 11:13 AM

Additionally you can see if this issue still happens with 2.79 builds from: https://builder.blender.org/download/

I can confirm that the stable build of 2.79 still exhibits this behaviour.

The version I downloaded identifies itself as:

After editing a file for a bit - mostly experimenting with making screen layouts, then saving the file, I see this in the Terminal and the Finder view:

After executing touch *.blend in the folder containing the files, the .blend file is visible in Finder again.

cheers
-jg-

Same problem.
When Blender to save the .blend1 backup file it is invisible in the Finder until something is updated (not related to Blender, since it may already be closed).
Although new .blend files appear immediately when you save it via Save As.

macOS 10.14.3
Blender 2.79b and 2.8

I cannot reproduce it here on 10.14.3 and Blender 2.8

Sebastian Parborg (zeddb) closed this task as Archived.Mar 1 2019, 2:10 PM
Sebastian Parborg (zeddb) claimed this task.

As I said before, I think this is a finder issue and not a blender issue. If we save files and they show up correctly in the terminal but not in finder, there is not much we can do.

I am surprised to hear that this has been archived.
Imagine the impact on a user that relies on the Finder for file management.
From their perspective, blender has lost the changes to their model.

-jg-